Announcement

Collapse
No announcement yet.

!!!!Help!!!! M50 swap cooling fan issue

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    !!!!Help!!!! M50 swap cooling fan issue

    I decided to go with the stock auxiliary fan for cooling so i can use the existing circuits, plugs, connectors, etc. The problem is the fan will not turn on when the car is running and gets hot. It will turn on with the ignition in the on position when i jump the low speed and high speed terminals at the radiator fan switch. I checked all fuses, relays, connections and all check out.

    I have:

    1-new thermostat
    2-new 80/88c radiator fan switch
    3-new water pump

    With the car running, i jump the terminals at the fan switch for low speed and the fan comes on.However, also with the car running, if i jump the high speed terminals, fuse #18 blows. Also, i cannot seem to get all the air out of the system. I have the m42 318 is radiator with the built-in tank and I bled the system per the instructions i found on the forums and no use. If i run the car with the bleeder screw off, i start to get a jet of steam out of the bleeder screw hole and the temp gauge keeps rising and i turn it off at the 3/4 mark so i don't over heat it. I am at a loss and cannot think of anything else. Please help.

    #2
    anyone?

    Comment


      #3
      Try unscrewing the sensor (engine COLD) and see if coolant comes out. Sounds like there is air, possibly due to a clogged radiator maybe.

      When you bled the system, did you raise up the corner of the car that has the overflow tank? You want the tank to be the highest point. Run it with the cap off, adding coolant as needed until up to operating temp. Revving it up a few thousand RPM every once in a while will help move coolant and air around.
      sigpic

      Comment


        #4
        I would suggest to make sure the sensor is good first.
        When I did my swap, I first tried an Uro sensor. The sensor seemed to not be calibrated correctly, or just faulty. Tried a different brand and it functioned like it was supposed to.

        Just stick the sensor in a bowl of water and boil it. Hold a multimeter on the pins that you're testing to make sure it 'close' when its supposed to.
        PNP Adapter Harness Wiring for M52TU, M54, S54, M60, M62, M62TU, S62, M50, S50, M52, S52 & MORE

        sigpic

        Comment


          #5
          Originally posted by sweet3 View Post
          Just stick the sensor in a bowl of water and boil it. Hold a multimeter on the pins that you're testing to make sure it 'close' when its supposed to.
          That was about to say....Go for it!
          Instagram

          Comment


            #6
            Does your heat work inside the car?


            Sent from my iPhone using Tapatalk
            /// MTech Belts ///


            S52 BUILD


            Instagram: @martino_motorsport

            Comment

            Working...
            X