Announcement

Collapse
No announcement yet.

M50 0bd1 e30 1988 325 car fuel and spark but no start

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    M50 0bd1 e30 1988 325 car fuel and spark but no start

    update Iíve got spark and fuel, not getting injection pulse?
    I have 12v to injectors with key in on position
    I have a good cps
    Good ecu
    I believe my wiring is right I have a check engine light working
    And I hear icv hum


    Wiring harness came from 525it and engine
    Believe the car was a 95 it had a red label ecu
    Unknown if it has asc, Iíve went through and wired the c101 with a good pin out
    I have one car thatís 24v with auto e36 harness from 93 car
    I have confirmed the parts Iím using work in that car
    Iíve confirmed my ecu and cps work
    I feel a click over a relay I canít tell if itís the dme one or the fuel one
    The car is getting fuel but no spark
    I donít have the o2 sensor wire hooked up is the onlt thing

    Check engine light doesnít turn on on dash for some reason
    All grounds look good
    Ecu is grounded at battery tray in front

    What could keep me from having spark does my check engine light have to be on?
    Last edited by e30m20TurbO7; 07-02-2019, 07:36 PM.

    #2
    Can anyone help guide me and tell me if they know if a car that has 413 label ecu can have asc or not

    Comment


      #3
      Does your ICV hum when the key is turned to the "on" position?
      Did you confirm that pin 7 at your C101, green, for ignition switch, has both wires (a large 14 gauge and a small 20 gauge) connected? If you are running an adapter, don't worry about this.
      DME securely grounded to chassis?
      Have you bumped anything under the dash? Make sure the green loop wire for the fuel pump lockout is connected under the dash still (if you have a factory 13 button computer installed, never mind this)

      ASC shouldn't have anything to do with this job, and from what I remember, the majority of the components are on the chassis side of the E34/E36, not the engine side.
      Autobahn Motorsport - Portland, Oregon
      @autobahnmotorsport
      '88 M5 | '88 325i | '88 325is | '88 330is | '91 325is | '91 M-Technic 325ic | '93 740il | '03 325it

      Comment


        #4
        ICV hums when key ignition is on
        green wire #7 has the small wire attached to it and the big wire going to pin seven
        the ecu is grounded to bare metal at a factory grounding point where the battery tray is in the engine bay. {my battery is in back just referring to area}
        the car cranks and get fuel
        I've got 12v to the coils according to my volt meter
        power to pin seven when key ignition is on
        I've tried on. my other car testing cps and ecu's


        Originally posted by e30austin View Post
        Does your ICV hum when the key is turned to the "on" position?
        Did you confirm that pin 7 at your C101, green, for ignition switch, has both wires (a large 14 gauge and a small 20 gauge) connected? If you are running an adapter, don't worry about this.
        DME securely grounded to chassis?
        Have you bumped anything under the dash? Make sure the green loop wire for the fuel pump lockout is connected under the dash still (if you have a factory 13 button computer installed, never mind this)

        ASC shouldn't have anything to do with this job, and from what I remember, the majority of the components are on the chassis side of the E34/E36, not the engine side.

        Comment


          #5
          Bump

          Comment


            #6
            update Iíve got spark and fuel, not getting injection pulse?



            Did you install the 24v fpr? You can get fuel but not enough to fire the injectors w/o it.
            Confirm engine to chassis ground.
            Good luck!

            Comment


              #7
              Will a car crank if the engine ground is bad ?
              Itís definitely connected but it made just be a bad ground it self.
              If the cars intake doesnít have all the vacuum lines hooked up will the car not fire without there pulling vacuum on FPr?
              Originally posted by bradmer View Post
              update Iíve got spark and fuel, not getting injection pulse?



              Did you install the 24v fpr? You can get fuel but not enough to fire the injectors w/o it.
              Confirm engine to chassis ground.
              Good luck!

              Comment


                #8
                Originally posted by bradmer View Post
                update Iíve got spark and fuel, not getting injection pulse?



                Did you install the 24v fpr? You can get fuel but not enough to fire the injectors w/o it.
                Confirm engine to chassis ground.
                Good luck!
                If you're not getting pulses, then you have no fuel.. Same with spark, just because you have 12 vdc to the coils with the ignition on does not mean you have spark.
                88 e30/s50 gt35r turbo m3



                96 gt4094r turbo m3
                452 rwhp, 455 rwtq at 14 psi 91 octane
                681 rwhp, 684 rwtq at 25 psi E65

                Comment


                  #9
                  ive confirmed spark with coil out and spark plug
                  ive also confirmed fuel with the line off?
                  no help here ???

                  Originally posted by m3boost View Post
                  If you're not getting pulses, then you have no fuel.. Same with spark, just because you have 12 vdc to the coils with the ignition on does not mean you have spark.

                  Comment


                    #10
                    Bump

                    Comment


                      #11
                      I will pay someone to help me in so cal
                      If anyone knows any 24v guys or any shops local
                      Confirmed fuel lines are Hooked up right
                      Fuel to the rail
                      Spark when I take a coil and put a spark plug in it
                      This is giving me the worst headache please helpn

                      Comment


                        #12
                        remove the hose that goes to the manifold from the brake booster.. spray some carb cleaner inside the manifold through that hole. quickly reconnect the hose and try to start the car. If you do have spark, it should start but will quickly die after a few seconds. And if it does start, then its a fuel related issue. Check for 12vdc at the injectors with the ignition on.. go to autozone a rent a set of noid lights to check for injector pulses.
                        88 e30/s50 gt35r turbo m3



                        96 gt4094r turbo m3
                        452 rwhp, 455 rwtq at 14 psi 91 octane
                        681 rwhp, 684 rwtq at 25 psi E65

                        Comment


                          #13
                          I realized that there is no diagnostic port on my engine harness.
                          If anyone wants to know how to make your car start without one ground pin 22 on ecu

                          Comment

                          Working...
                          X