Announcement

Collapse
No announcement yet.

The comprehensive DOHC engine swap thread.

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by FishEye View Post
    I just bought a M50B25 TU from a 94 325... I have a 91 318is... Can I use the tranny and driveshaft from the same e36 325? My tranny just blew today so it's time to get serious with this swap.. Please help!
    I know for sure you can use the transmission, but driveshaft I think needs to be from an auto E36 or something. Search for driveshafts and they list the combos somewhere...
    Simon
    Current Cars:
    -1986 BMW 325e & 1968 Datsun Roadster 2000
    Previous Car Count : 21 ... and climbing...

    Make R3V Great Again -2020

    Comment


      If Im swapping from an OBD2 plastic valve cover to an OBD1 metal valve cover, what is interchangeable and what isnt???

      I believe the coil packs are different. Do I need to get new valvecover gaskets too?? Anything else?
      Simon
      Current Cars:
      -1986 BMW 325e & 1968 Datsun Roadster 2000
      Previous Car Count : 21 ... and climbing...

      Make R3V Great Again -2020

      Comment


        Originally posted by 2mAn View Post
        If Im swapping from an OBD2 plastic valve cover to an OBD1 metal valve cover, what is interchangeable and what isnt???

        I believe the coil packs are different. Do I need to get new valvecover gaskets too?? Anything else?
        Thanks... Ill do some digging.. I believe the plastic valve cover will fit on the obd1 block and the coils will plug up and work but there will be a problem fitting the coils on the valve cover because the mounting is different for the coils i believe... Not too sure on that

        Comment


          Originally posted by roznic View Post
          Guys, need help on brakes..
          I am running IX booster with 95 e36 m3 MC and 2002 remote res, I have the 2002 connectors that plug into MC but they're much skinnier than the grommets in MC! Any ideas how to make it work or if any other grommets, does anybody have p/n??
          Thx in advance.

          Didnt see anyone answer this, but if you searched this thread, I updated my previous post where I detail the part #s... Anyways, the grommet part number is 34 31 1 121 911.

          Simon
          Current Cars:
          -1986 BMW 325e & 1968 Datsun Roadster 2000
          Previous Car Count : 21 ... and climbing...

          Make R3V Great Again -2020

          Comment


            Originally posted by 2mAn View Post
            If Im swapping from an OBD2 plastic valve cover to an OBD1 metal valve cover, what is interchangeable and what isnt???

            I believe the coil packs are different. Do I need to get new valvecover gaskets too?? Anything else?
            bump for answers...
            Simon
            Current Cars:
            -1986 BMW 325e & 1968 Datsun Roadster 2000
            Previous Car Count : 21 ... and climbing...

            Make R3V Great Again -2020

            Comment


              Valve cover gasket, coil packs with all the 10mm nuts, since obd2 uses bolt not nuts. Think that's it.
              IG: @Baye30

              FRONT VALENCE IS ZENDER!!! STOP FILLING MY PM BOX PPL!!!

              Comment


                Hey guys, I've been scouring the forum for my s50 swap for a few months now. I'm finally at the point where the motor is in the car but not starting. I've done a ton of searching but I'd like to confirm that I'm not crazy; at no point should the 12v pos be touching the ground, anywhere correct? As of right now, using a continuity tester the 12v distribution block lights up when i test it against a ground, as does the pos cable at the trunk batter, lights up against the battery ground.

                The strange thing is that I would expect this to blow a bunch of fuses/relays but as far as I can tell on the fuses are intact and the main relay clicks when ignition is switched on, it even cranks though I'm not sure it should.

                So before I spend hours tracing this, can someone please confirm that the 12v SHOULD NOT be touching ground anywhere?

                Edit: Apparently this is normal, just got it to start up.
                Last edited by puffxy; 10-21-2014, 06:34 PM.

                Comment


                  Hi. I just swaped m50b30 ( e28 engine mounts)
                  I also bought e34 540i brake booster kit, but rod on 540i brake booster more short, than e30 stock.
                  What upgrades it needed? I want to mount it on firewall.

                  Comment


                    Recently got an S52 swapped 1991 318i, the tachometer/temp gauges weren't working. For the temp gauges I figured it would be the temp sensor, but it seems I have only a 2 pin blue temp sensor in my block (is my car OBD1 swapped?). For the tach, the harness adapter appears to have the tach sensor correctly wired, and I do have a 1989 E30 325i M20 coding plug in my cluster, yet it still doesn't work. Any ideas?

                    Comment


                      there's no such thing as a "tach sensor". ;)

                      it should be a black wire from the engine harness going to pin 9 from X20 #20.

                      for the coolant you need to install an E30 sensor and add the wire to the harness, connecting it to pin 4 on the C101.
                      Build thread

                      Bimmerlabs

                      Comment


                        Turns out the 1991 car had some ungodly amount of rust underneath so I'll be swapping the entire engine over to a 1985 M10 E30. I looked at diagrams for all the pinouts and know where every one would go, but I need help finding the part number for the engine side square C101 and C104, and the types of pins it uses. Would it be easier to just find someone with a plug cut out from the engine? How much would that cost vs. getting a new plug and pins
                        Last edited by Gaboer; 04-05-2015, 10:46 AM.

                        Comment


                          Originally posted by Gaboer View Post
                          Recently got an S52 swapped 1991 318i, the tachometer/temp gauges weren't working. For the temp gauges I figured it would be the temp sensor, but it seems I have only a 2 pin blue temp sensor in my block (is my car OBD1 swapped?). For the tach, the harness adapter appears to have the tach sensor correctly wired, and I do have a 1989 E30 325i M20 coding plug in my cluster, yet it still doesn't work. Any ideas?
                          Search under my started threads for Tach Test. I had the same issue and it is resolved in there with pics.

                          Comment


                            Saw your thread, that was really helpful.
                            So this is what I have right now, does this look good?

                            What I'm wondering is for the tech, do i use pin 20 on the X20, or do I just directly wire it to my DME?

                            Comment


                              Originally posted by Gaboer View Post
                              Saw your thread, that was really helpful.
                              So this is what I have right now, does this look good?

                              What I'm wondering is for the tech, do i use pin 20 on the X20, or do I just directly wire it to my DME?
                              There is mention that there are different methods for the late model. Mine was tapped into the DME harness because I had the 3 prong plug as pictured. If you do not have that plug you may have a different resolution. But yes, the C104 to DME you listed is accurate.

                              Comment


                                Found out that pin 1 doesn't exist on my S52 loom, guess I don't need the oil level sensor lol. Anyways, I just thought, is the DME pinout for the S50 and S52 the same? I just wanted to make sure that the DME pinout for 74/17 are the same since your thread was for an M50 engine.

                                Comment

                                Working...
                                X