Announcement

Collapse
No announcement yet.

1987 325is turbo build with MS ECU starting problem!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    1987 325is turbo build with MS ECU starting problem!

    I have an 87 325is with a bolt on turbo kit. I have a mega squirt with a base tune for it and when I go to start the car I have spark from the coil to the cap. Nothing after the cap. I have replaced the plugs, plug wires, coil, cap/rotor, CPS sensor. In not sure why I can't get spark after the cap but even with everything replaced I get nothing. Does any one have any idea what this could be?

    #2
    missing or damaged rotor? bad aftermarket parts? the 'key' to the rotor mount is off?
    Build thread

    Bimmerlabs

    Comment


      #3
      If all the parts are new is there any other possible options? I'll look into getting fresh parts again but both rotors seem fine. What's the rotor key?

      Comment


        #4
        it's the part that the rotor bolts to. It's keyed to the camshaft sprocket, so technically you can only put it on one way. Except, you can actually put it on wrong (I know because I've done it) which will damage the rotor.
        Build thread

        Bimmerlabs

        Comment


          #5
          I'll look into that when I'm back at it today but I bolted back the way I took it off. Hopefully that's it.

          Comment


            #6
            How did you end up bolting in on wrong?

            Comment


              #7
              easy. I thought I had it lined up. It turned out I had a used one with a dent in it, so it 'felt' like it keyed in the correct spot, but it was actually 180 degrees off. Also it ruined the new $80 cap and rotor I had just put in.. :(
              Build thread

              Bimmerlabs

              Comment


                #8
                I have a new cap and rotor laying around Iím not going to use if you want it for like $20 plus shipping. It has 500 miles on it


                Sent from my iPhone using Tapatalk

                Comment

                Working...
                X