Announcement

Collapse
No announcement yet.

Windows, sunroof, heater fan and who knows what else stopped working on my 88 M3

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Windows, sunroof, heater fan and who knows what else stopped working on my 88 M3

    Also, maybe unrelated, the tach started jumping all over the place, or not reading at all, or working.

    It appears that this may be a ground issue as these are all separate circuits. One guy on YouTube fixed his E30 by moving a wire on his starter solenoid. I would like to know why he moved the ground wire a different terminal, but his video may be a clue. It appears that the starter has a separate ground terminal, so I would like to see a diagram of what is inside the solenoid. I think it disconnects accessory circuits to protect from the back EMF of the starter motor.

    I just got done with major service and got it back on the road. Everything was working on the beginning of a test ride but, I think, it quit on the last re-starting.

    If so, it looks like a major hassle to get at the starter. It can't be seen from the underside and barely visible under the intake plenum after taking off the FI flow sensor. Any info, or tips of any kind would be appreciated.
    Last edited by Del Schier; 05-13-2022, 03:57 PM.

    #2
    It started working again after I took out unloader relay K7 and cycled and tested it on the bench. I will clean and tighten the starter connections and if it happens again replace K7. I'll keep you all posted.

    Comment

    Working...
    X