Announcement

Collapse
No announcement yet.

Ix suspension question. Rubbing

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Ix suspension question. Rubbing

    I running H&R springs and have no sway bar connected up front.
    Also i have offset solid CABS.

    I was balancing my wheels today an noticed some part of my strut housing around my upper part of my sway bar links running against my unibody. its worn threw they rubberized layer. Just curious if anybody has experienced this.

    It looks like it just may be the stud and bolt part of the links rubbing.
    sigpic
    1999 BMW 318Ti/M Hellrot Msport DD/Fun car
    1/2 1987 BMW 325is/M Future Spec e30 (track prep'd)
    1994 530It/A Alpinewise III Traded out
    1988 BMW 325ix/M Diamond Schwartz Recently sold :/
    1986 BMW 325e/m Bronzit Beige Metallic

    Get Involved!
    www.bluegrassbimmers.org
    OKI BMW Facebook group

    BMWCCA Member# 436428

    ZAKSPEED
    Quality BMW service "street, track, race"?
    Email: Zach Ketring @ Zach@Zakspeed.us

    #2
    bump
    sigpic
    1999 BMW 318Ti/M Hellrot Msport DD/Fun car
    1/2 1987 BMW 325is/M Future Spec e30 (track prep'd)
    1994 530It/A Alpinewise III Traded out
    1988 BMW 325ix/M Diamond Schwartz Recently sold :/
    1986 BMW 325e/m Bronzit Beige Metallic

    Get Involved!
    www.bluegrassbimmers.org
    OKI BMW Facebook group

    BMWCCA Member# 436428

    ZAKSPEED
    Quality BMW service "street, track, race"?
    Email: Zach Ketring @ Zach@Zakspeed.us

    Comment

    Working...
    X