Announcement

Collapse
No announcement yet.

User Profile

Collapse

Profile Sidebar

Collapse
Avatar
cwlo
Advanced Member
Last Activity: 09-09-2019, 06:08 AM
Joined: 09-23-2015
Location: Chicago
  •  
  • Filter
  • Time
  • Show
  • Source
Clear All
new posts

  • cwlo
    replied to Rear suspension setup
    So the rear adjusters were fine, but I took a little camber out to be 2-2.25. That seemed to help, Unfortunately, I also hooked up the stock rear bar, which I did not like. Was surprised at the difference....
    See more | Go to post

    Leave a comment:


  • cwlo
    replied to Rear suspension setup
    Yes, I am thinking the same thing on looking at the rear camber/toe adjusters. GC kit is new, and toe was checked with plates....might investigate that a little more as well. Anyway, I appreciate the...
    See more | Go to post

    Leave a comment:


  • cwlo
    replied to Rear suspension setup
    No, car never corner balanced....
    See more | Go to post

    Leave a comment:


  • cwlo
    replied to Rear suspension setup
    Yes, all new poly ta bushings, and Condor subframe and diff. Koni's a couple years and maybe 500 miles on em. I'm about half a turn from full stiff on the Koni's.
    See more | Go to post

    Leave a comment:


  • cwlo
    replied to Rear suspension setup
    One more thing.....every once and a while, I get rear wheel hop on mid-turn and exit. Not sure if a bump is starting the process, or if its some suspension dynamics going on as I apply throttle?
    See more | Go to post

    Leave a comment:


  • cwlo
    replied to Rear suspension setup
    Thanks guys. So I think I will take the rear camber down to 2-2.25 and see the results. I am running about 1/8" toe in on the rear. I have the stock rear bar installed but not hooked up, so I...
    See more | Go to post

    Leave a comment:


  • cwlo
    started a topic Rear suspension setup

    Rear suspension setup

    I am hoping to increase my rear traction, as I am having a hard time getting power down. Car is setup with a GC coilover setup, 440/660 spring. Front IE bar on soft with M3 mounts, no rear bar. I'm...
    See more | Go to post

  • cwlo
    replied to Melon's Autocross Thread
    So you didn't mention your camber settings. I'm running 3.5 front, 2.5 rear, and I'm strongly thinking of lowering the rear negative camber, as I'm unable to get decent traction under acceleration. ...
    See more | Go to post

    Leave a comment:

No activity results to display
Show More
Working...
X