R3VLimited Forums

Go Back   R3VLimited Forums > E30 Technical Forums > Engine & Drivetrain > M42

Reply
 
Thread Tools
Old 03-21-2016, 01:54 PM   #1
sketchkid
Advanced Member
 
Join Date: Dec 2015
Location: webster, tx
Posts: 147
M42 rough idle

It's rough idling when in neutral, it was sitting 12years, I changed fuel filter, sparks, and oil. Also there is a huge delay when I hit the gas. Is it the MAF, maybe still old gas in system? I only added one tank of fresh after new fuel filter, or could it be Injectors. What could it be that I could check or change? Videos below





Sent from my iPhone using Tapatalk
__________________
91 318is "under construction"
2007 328i - daily
sketchkid is offline   Reply With Quote
Old 03-21-2016, 02:00 PM   #2
TobyB
No R3VLimiter
 
TobyB's Avatar
 
Join Date: Oct 2011
Location: Carnation WA usa
Posts: 3,819
Hole in the air intake boot.
t
__________________
Quote:
now, sometimes I just mess with people. It's more entertaining that way. george graves
TobyB is offline   Reply With Quote
Old 03-22-2016, 06:07 PM   #3
sketchkid
Advanced Member
 
Join Date: Dec 2015
Location: webster, tx
Posts: 147
So update: today she fired up and rough idle for about 10-15 mins then idle was better much more stable. I don't know if the lil bit of fresh gas is just now getting thru * I hadn't drove it anywhere yet just firing it up for testing. Today the only thing I did was put in a new MAF, I do kinda smell fuel inside the car a bit, so right now I'm with in the week I'll be putting in new spark plug wire and maybe fuel pump and coils. I'm just ready for it to run continuously smooth at start up so that I could trust it a enough for a ride around the block. I'm gonna put more fresh fuel in here tomorrow too or this weekend. Any other pointer for you'll guy would def be appreciated.



Sent from my iPhone using Tapatalk
__________________
91 318is "under construction"
2007 328i - daily
sketchkid is offline   Reply With Quote
Old 03-22-2016, 06:07 PM   #4
sketchkid
Advanced Member
 
Join Date: Dec 2015
Location: webster, tx
Posts: 147
Quote:
Originally Posted by TobyB View Post
Hole in the air intake boot.
t

It no whole it but the bottom hose connected to it is held by black tape that can't be good so it will be replaced


Sent from my iPhone using Tapatalk
__________________
91 318is "under construction"
2007 328i - daily
sketchkid is offline   Reply With Quote
Old 03-23-2016, 06:25 AM   #5
CaliDazze
Advanced Member
 
Join Date: Feb 2015
Location: FarFar EastBay
Posts: 190
My car was doing this when I first got it. Start it, would run real rough near idle, give it some gas and would run ok at higher rpms, then once warm would run ok at idle.

I found some old/craked vacuum lines near/under the intake manifold. Replaced them and it immediately started and ran great.

Since the cars been sitting for a long time you can almost guarantee there is a bad hose/vacuum leak somewhere. It a good place to start and hoses are cheap.
CaliDazze is offline   Reply With Quote
Old 03-29-2016, 07:12 PM   #6
sketchkid
Advanced Member
 
Join Date: Dec 2015
Location: webster, tx
Posts: 147
Yep I found one right under intake but part number is kinda rubbed off so I can't see it to order new one


Sent from my iPhone using Tapatalk
__________________
91 318is "under construction"
2007 328i - daily
sketchkid is offline   Reply With Quote
Old 03-29-2016, 07:31 PM   #7
roguetoaster
No R3VLimiter
 
roguetoaster's Avatar
 
Join Date: Jan 2012
Location: Port Republic, MD
Posts: 3,284
Don't order new vac hoses unless emissions inspections require it. Instead you should search for the mess under the intake thread in this section and read the info therein.

If you must get OE hoses you can look up the part numbers here: http://bmwfans.info/parts-catalog/E3...M42/L-M/browse

Keep in mind that some hoses in the diagram may not look like what you have on the car.
roguetoaster is offline   Reply With Quote
Old 03-30-2016, 10:18 AM   #8
sketchkid
Advanced Member
 
Join Date: Dec 2015
Location: webster, tx
Posts: 147
Quote:
Originally Posted by roguetoaster View Post
Don't order new vac hoses unless emissions inspections require it. Instead you should search for the mess under the intake thread in this section and read the info therein.

If you must get OE hoses you can look up the part numbers here: http://bmwfans.info/parts-catalog/E3...M42/L-M/browse

Keep in mind that some hoses in the diagram may not look like what you have on the car.


So I put my foot on pedal all the way and it hardly get gas I have to slightly rev pedal to hear the engine power up???
__________________
91 318is "under construction"
2007 328i - daily
sketchkid is offline   Reply With Quote
Old 04-01-2016, 12:27 AM   #9
sketchkid
Advanced Member
 
Join Date: Dec 2015
Location: webster, tx
Posts: 147
Ok so where is a full detail to the mess under the intake so I can fix this idle issue and coolant leak that driving me crazy?


Sent from my iPhone using Tapatalk
__________________
91 318is "under construction"
2007 328i - daily
sketchkid is offline   Reply With Quote
Old 04-01-2016, 04:38 AM   #10
roguetoaster
No R3VLimiter
 
roguetoaster's Avatar
 
Join Date: Jan 2012
Location: Port Republic, MD
Posts: 3,284
If you want answers you need to search first and ask second as the thread that you seek is at the bottom of the section main page.
roguetoaster is offline   Reply With Quote
Old 04-01-2016, 07:02 AM   #11
jdt10768
Grease Monkey
 
jdt10768's Avatar
 
Join Date: Feb 2013
Location: SC
Posts: 389
also clean out ICV with carb cleaner, and check/replace those 2 hoses that connect it
jdt10768 is offline   Reply With Quote
Old 04-02-2016, 11:30 AM   #12
sketchkid
Advanced Member
 
Join Date: Dec 2015
Location: webster, tx
Posts: 147
So today's I cleaned ICV still bad idle on cold start then when I hit gas I hear popping and have to tap gas for power


Sent from my iPhone using Tapatalk
__________________
91 318is "under construction"
2007 328i - daily
sketchkid is offline   Reply With Quote
Old 04-02-2016, 11:33 AM   #13
sketchkid
Advanced Member
 
Join Date: Dec 2015
Location: webster, tx
Posts: 147
Video below


Sent from my iPhone using Tapatalk
__________________
91 318is "under construction"
2007 328i - daily
sketchkid is offline   Reply With Quote
Old 04-05-2016, 01:46 PM   #14
unixnerd
Noobie
 
Join Date: Mar 2016
Location: Aviemore, Scotland
Posts: 12
Take off the top half of the intake manifold, it's not a big job. Fix / replace whatever mess you find under there and you'll be smiling by the end.
__________________
My BMW site: www.unixnerd.demon.co.uk since 1996
unixnerd is offline   Reply With Quote
Old 04-05-2016, 01:48 PM   #15
sketchkid
Advanced Member
 
Join Date: Dec 2015
Location: webster, tx
Posts: 147
Lost key today waiting on Bmw to send me a new one


Sent from my iPhone using Tapatalk
__________________
91 318is "under construction"
2007 328i - daily
sketchkid is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 11:32 AM.


Powered by vBulletin® Version 3.8.10
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2004 - 2020 R3VLimited LLC