R3VLimited Forums

Go Back   R3VLimited Forums > E30 Technical Forums > General Technical

Reply
 
Thread Tools Search this Thread
Old 01-11-2019, 09:57 PM   #1
Vincent Brick
E30 Modder
 
Vincent Brick's Avatar
 
Join Date: Feb 2013
Location: Bottom Left Corner
Posts: 858
"CHECK" on cluster flashes, no check panel lights and everything works?

Each time I start my car ('91 325i), the "CHECK" light on the cluster begins flashing while cranking, but no check panel lights come on, and I have to press the check panel button to make it stop. I have oil and coolant, I can't find any burnt out bulbs, and I get the notification even if lights are turned off. It started a week ago, after driving a few minutes I would get the flash, but it was intermittent. within a few days it has escalated into an every-time thing, and like I said, it starts as soon as I start cranking. Its not the normal brake light behavior, that goes off at the touch of the brake pedal, doesn't require a button press. I do think that my oil level sensor may have failed.



I did repair a broken solder joint on my check panel a month ago, to correct a false alert for burnt bulb, but the repair fixed the issue and everything has been fine with it, so I am not sure if they are related.


Anyone have any ideas what is going on? Thanks!
__________________

1991 325i Sport - Calypsorot Metallic - DAILY DRIVEN

WTB in SoCal: 8"/10" Lukebox, leather Sport steering wheel, 60L MotoMeter fuel gauge, Thule/Yakima roof rack
Vincent Brick is offline   Reply With Quote
Old 01-12-2019, 08:00 AM   #2
dnguyen1963
R3VLimited
 
dnguyen1963's Avatar
 
Join Date: Nov 2011
Location: South Bend, IN
Posts: 2,501
The check light on the cluster is supposed to go on after you start the car to remind you to check the overhead panel for any broken light. It should go off after you hit the brake. You can start the car with your foot on the brake to eliminate this annoying light or take the bulk out of the cluster. Or put a piece of tape over it. Your car will not explode if you do nothing so don't worry about it.
dnguyen1963 is offline   Reply With Quote
Old 01-12-2019, 06:42 PM   #3
Vincent Brick
E30 Modder
 
Vincent Brick's Avatar
 
Join Date: Feb 2013
Location: Bottom Left Corner
Posts: 858
^^^ I know what you are referring to, that is normal, but this is different. Even starting the car with the foot on the brake, the light starts flashing immediately upon turning the key, and I have to press the button on the check panel to make the flashing stop, not merely touch the brake pedal after starting like normal, like it behaved up until this week.

Like I said, I am pretty sure my oil level sensor has failed, I checked my oil recently and the level was below where it normally alerts me on the check panel (high mile, daily driven car so it uses a bit of oil). I'm just not sure that what I am experiencing is a symptom of that sensor failure, don't want to throw parts at it. I think that sensor is 3 wires IIRC, which is more than you would need for a simple switch, so I think testing that is what I am going to research next, but I suspect I'm barking up the wrong tree there.

Thanks.
__________________

1991 325i Sport - Calypsorot Metallic - DAILY DRIVEN

WTB in SoCal: 8"/10" Lukebox, leather Sport steering wheel, 60L MotoMeter fuel gauge, Thule/Yakima roof rack
Vincent Brick is offline   Reply With Quote
Old 01-13-2019, 09:57 AM   #4
Todd Black 88
No R3VLimiter
 
Todd Black 88's Avatar
 
Join Date: Oct 2007
Location: North Vancouver B.C.
Posts: 3,383
Does the oil light come on when you press the test button on the check panel?

I suspect your brake light switch has failed.
__________________
Quote:
Originally Posted by codyep3 View Post
I hope to Christ you have looks going for you, because you sure as fuck don't have any intelligence.
2001 silver/Blk 325 cabby. SOLD
1988 Blk/Blk e30 factory wide body kit car SOLD
1992 DS/BLK 325 m-tech II apperance pack cabby SOLD!
2002 325xit Sil/blk. SOLD
2012 328i xdrive touring. Wht/blk. SOLD
2009 135 cabby. monacoblue/blk leather SOLD
2007 Z4m coupe. Silver grey/black/ aluminum. 1of50
2010 F650gs twin
2016 M235i cabby. Mineral grey/Red leather
Todd Black 88 is offline   Reply With Quote
Old 01-13-2019, 11:57 PM   #5
Vincent Brick
E30 Modder
 
Vincent Brick's Avatar
 
Join Date: Feb 2013
Location: Bottom Left Corner
Posts: 858
Quote:
Originally Posted by Todd Black 88 View Post
Does the oil light come on when you press the test button on the check panel?

I suspect your brake light switch has failed.



Neither oil nor coolant lights illuminate when pressing the test button, I don't believe they ever did, even back when both were known to work (low coolant light alerted me to a TB heater leak once), though my memory could be wrong. I had assumed that to be normal, that only the light indicators illuminated on test. I was just working on another E30 today too, I wish I would have thought to see how that check panel behaves.


Brake lights work fine, switch isn't even that old, replaced it a couple years ago. I do still get the brake light warning illuminated upon starting the car, but pressing the brake pedal only turns that check panel light off, the CHECK continues flashing in the cluster until I press the test button.



I haven't had time to look up an oil level sensor test yet, might take a few days to find a test procedure and perform it.
__________________

1991 325i Sport - Calypsorot Metallic - DAILY DRIVEN

WTB in SoCal: 8"/10" Lukebox, leather Sport steering wheel, 60L MotoMeter fuel gauge, Thule/Yakima roof rack
Vincent Brick is offline   Reply With Quote
Old 01-14-2019, 12:04 AM   #6
gath
E30 Addict
 
Join Date: Aug 2008
Location: WA
Posts: 573
For most E30s, this is how your check panel should illuminate (borrowed image)

gath is offline   Reply With Quote
Old 01-14-2019, 11:42 AM   #7
Todd Black 88
No R3VLimiter
 
Todd Black 88's Avatar
 
Join Date: Oct 2007
Location: North Vancouver B.C.
Posts: 3,383
Quote:
Originally Posted by Vincent Brick View Post
Neither oil nor coolant lights illuminate when pressing the test button, I don't believe they ever did, even back when both were known to work (low coolant light alerted me to a TB heater leak once), though my memory could be wrong. I had assumed that to be normal, that only the light indicators illuminated on test. I was just working on another E30 today too, I wish I would have thought to see how that check panel behaves.


Brake lights work fine, switch isn't even that old, replaced it a couple years ago. I do still get the brake light warning illuminated upon starting the car, but pressing the brake pedal only turns that check panel light off, the CHECK continues flashing in the cluster until I press the test button.

I haven't had time to look up an oil level sensor test yet, might take a few days to find a test procedure and perform it.

All the lights are supposed to be on when the test button is pressed. The button is there to confirm the lights in the check panel, work.
__________________
Quote:
Originally Posted by codyep3 View Post
I hope to Christ you have looks going for you, because you sure as fuck don't have any intelligence.
2001 silver/Blk 325 cabby. SOLD
1988 Blk/Blk e30 factory wide body kit car SOLD
1992 DS/BLK 325 m-tech II apperance pack cabby SOLD!
2002 325xit Sil/blk. SOLD
2012 328i xdrive touring. Wht/blk. SOLD
2009 135 cabby. monacoblue/blk leather SOLD
2007 Z4m coupe. Silver grey/black/ aluminum. 1of50
2010 F650gs twin
2016 M235i cabby. Mineral grey/Red leather
Todd Black 88 is offline   Reply With Quote
Old 01-14-2019, 06:37 PM   #8
Vincent Brick
E30 Modder
 
Vincent Brick's Avatar
 
Join Date: Feb 2013
Location: Bottom Left Corner
Posts: 858
Quote:
Originally Posted by Todd Black 88 View Post
All the lights are supposed to be on when the test button is pressed. The button is there to confirm the lights in the check panel, work.

So that leads me to believe that there is an error in my check panel itself, that the coolant and oil lights are not illuminating when they should be. But even if they were alerting me, its still going to be an issue because it would seem that one of those lights are being triggered despite the fact the motor has plenty of oil and coolant.


Good info, but its going to require more digging.
__________________

1991 325i Sport - Calypsorot Metallic - DAILY DRIVEN

WTB in SoCal: 8"/10" Lukebox, leather Sport steering wheel, 60L MotoMeter fuel gauge, Thule/Yakima roof rack
Vincent Brick is offline   Reply With Quote
Old 01-14-2019, 08:14 PM   #9
jeffnhiscars
R3V Elite
 
jeffnhiscars's Avatar
 
Join Date: Jun 2011
Location: Officially Tampa
Posts: 5,541
A faulty coolant level sensor would do that
__________________
Deck Lid Shocks on hand

Seat shocks in hand and ready to ship....supply is limited
https://www.r3vlimited.com/board/sho...86#post4944786
Alice the Time Capsule
http://www.r3vlimited.com/board/showthread.php?t=360504
87 Zinno Cabrio barn find 98k and still smells like a barn. Build thread http://www.r3vlimited.com/board/show...20#post3455220
jeffnhiscars is offline   Reply With Quote
Old 01-15-2019, 12:25 AM   #10
Vincent Brick
E30 Modder
 
Vincent Brick's Avatar
 
Join Date: Feb 2013
Location: Bottom Left Corner
Posts: 858
Next free time I get I will be looking up test procedures for both sensors and going to town on 'em.
__________________

1991 325i Sport - Calypsorot Metallic - DAILY DRIVEN

WTB in SoCal: 8"/10" Lukebox, leather Sport steering wheel, 60L MotoMeter fuel gauge, Thule/Yakima roof rack
Vincent Brick is offline   Reply With Quote
Old 01-15-2019, 08:06 AM   #11
Todd Black 88
No R3VLimiter
 
Todd Black 88's Avatar
 
Join Date: Oct 2007
Location: North Vancouver B.C.
Posts: 3,383
Coolant sensor is a known issue. Pull the connector off the sensor in the reservoir, and put a wire jumper in it.
__________________
Quote:
Originally Posted by codyep3 View Post
I hope to Christ you have looks going for you, because you sure as fuck don't have any intelligence.
2001 silver/Blk 325 cabby. SOLD
1988 Blk/Blk e30 factory wide body kit car SOLD
1992 DS/BLK 325 m-tech II apperance pack cabby SOLD!
2002 325xit Sil/blk. SOLD
2012 328i xdrive touring. Wht/blk. SOLD
2009 135 cabby. monacoblue/blk leather SOLD
2007 Z4m coupe. Silver grey/black/ aluminum. 1of50
2010 F650gs twin
2016 M235i cabby. Mineral grey/Red leather
Todd Black 88 is offline   Reply With Quote
Old 01-15-2019, 08:55 AM   #12
dnguyen1963
R3VLimited
 
dnguyen1963's Avatar
 
Join Date: Nov 2011
Location: South Bend, IN
Posts: 2,501
These sensors are cheap. I would replace all of them. They are all about 30 years old by now.
dnguyen1963 is offline   Reply With Quote
Old Yesterday, 07:22 PM   #13
Vincent Brick
E30 Modder
 
Vincent Brick's Avatar
 
Join Date: Feb 2013
Location: Bottom Left Corner
Posts: 858
Quote:
Originally Posted by Vincent Brick View Post
Next free time I get I will be looking up test procedures for both sensors and going to town on 'em.

Except I never got a chance, the day after this last post the problem went away completely, took me a day to even notice I didn't have to press the button. I guess I will revisit it if the issue reoccurs.
__________________

1991 325i Sport - Calypsorot Metallic - DAILY DRIVEN

WTB in SoCal: 8"/10" Lukebox, leather Sport steering wheel, 60L MotoMeter fuel gauge, Thule/Yakima roof rack
Vincent Brick is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 01:39 AM.


Powered by vBulletin® Version 3.8.10
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2004 - 2020 R3VLimited LLC