R3VLimited Forums

Go Back   R3VLimited Forums > E30 Technical Forums > General Technical

Reply
 
Thread Tools
Old 03-22-2018, 07:46 PM   #31
jhaurimn
R3VLimited
 
Join Date: Nov 2012
Location: Minnesota
Posts: 2,146
Quote:
Originally Posted by TeXJ View Post
Seems I have about the same issue as you. obd1 swapped m52b28, stock everything running a red label 413.

When coming to a stop, car in neutral, foot depressing brake, the revs go from about 700 then to 1k rpms...till I'm stopped, then it levels out. Also, at times, just as I put the clutch in to go to neutral, it will die. Doesn't happen often but it does that as well. This is with or without the AC on. IAC is good.
sounds exactly like my issue, just that its all at a bit higher rpms on my end.

if you find a solution for that, please post back on this thread
__________________
Current:
1989 325i
1988 M3
Past:
2001 330ci
2001 M3
jhaurimn is offline   Reply With Quote
Old 03-23-2018, 09:28 AM   #32
TeXJ
E30 Modder
 
Join Date: Apr 2010
Location: Allen, TX
Posts: 996
Quote:
Originally Posted by jhaurimn View Post
sounds exactly like my issue, just that its all at a bit higher rpms on my end.

if you find a solution for that, please post back on this thread
Will do, and if you happen to find a solution let me know as well. More than likely gonna let a mechanic look at mine.
__________________
1990 325is
m52b28
3.73lsd
1987 325is 5spd tranny
TeXJ is offline   Reply With Quote
Old 03-24-2018, 10:54 PM   #33
jhaurimn
R3VLimited
 
Join Date: Nov 2012
Location: Minnesota
Posts: 2,146
Quote:
Originally Posted by TeXJ View Post
Will do, and if you happen to find a solution let me know as well. More than likely gonna let a mechanic look at mine.
Sounds good. I will definitely keep updating this thread as i attempt to fix the problem, cant wait for the update that I do finally fix the issue. Ive been at it for 3 months now. :/

Going to try a "cigar" smoke test tomorrow to see if i can spot any vacuum leaks, and check the exhaust back pressure just to rule it out. My car seemed to produce a suction noise on cold starts that seems to get louder, so I am going to inspect tomorrow morning. I can see a steady stream of smoke out of the exhaust so I don't think that's the issue, but i want to rule everything out at this point that I can.
__________________
Current:
1989 325i
1988 M3
Past:
2001 330ci
2001 M3
jhaurimn is offline   Reply With Quote
Old 03-29-2018, 08:44 PM   #34
robby41
Noobie
 
Join Date: Dec 2017
Location: vacaville, ca
Posts: 23
i am having a similar issue with my 325e. it will fall off its face and would buck down at 70-75 or around 35 mph. cleaned icv multiple times and that fixed it for a short time but the problem always came back. changed spark plugs and ordered a coil and fuel filter.
robby41 is offline   Reply With Quote
Old 03-31-2018, 08:41 PM   #35
jhaurimn
R3VLimited
 
Join Date: Nov 2012
Location: Minnesota
Posts: 2,146
smoked tested car, no leaks. pretty much have my issues down to the possibility of:

-vanos seals (although this should cause idle issues which i am experiencing)
-bad o2 (o2 is less than 2 years old)
-bad chip (trm)
-bad harness
__________________
Current:
1989 325i
1988 M3
Past:
2001 330ci
2001 M3
jhaurimn is offline   Reply With Quote
Old 03-31-2018, 09:31 PM   #36
2mAn
Moderator
 
2mAn's Avatar
 
Join Date: Aug 2010
Location: Culver City
Posts: 12,700
Low on Power (obd1 m52)

Well, youíre getting there. Iíd start with a new o2 just as a precautionary and maintenance item and work from there. Chip should be easy to swap if you know someone who also has a similar setup.... hopefully itís not the Harness. Is it fully modified or do you have an adapter...

I just had a random idea. Since youíre in MN, if the o2 doesnít do anything and it appears to be electrical have you considered upgrading to a OBD2 setup with all the BS deleted from it? Better diagnostics should another issue arise
__________________
Simon
Current Cars:
-1988 BMW 325i
-1968 Datsun Roadster 2000 with Nissan Competition Package

Quote:
Originally Posted by ReallyDirtyThirty View Post
Just keep pushing it in... when you think you can't push it in any farther, push harder.
2mAn is online now   Reply With Quote
Old 04-01-2018, 07:25 AM   #37
TeXJ
E30 Modder
 
Join Date: Apr 2010
Location: Allen, TX
Posts: 996
I've thought about going from obd1 to obd2, was told that that would be a big process to complete.
__________________
1990 325is
m52b28
3.73lsd
1987 325is 5spd tranny
TeXJ is offline   Reply With Quote
Old 04-01-2018, 10:36 AM   #38
shootnjunky
E30 Addict
 
Join Date: Aug 2014
Location: ohio
Posts: 421
I had the clutch die thing happen and then I replaced the pcv and itís been fine
shootnjunky is offline   Reply With Quote
Old 04-01-2018, 12:43 PM   #39
TeXJ
E30 Modder
 
Join Date: Apr 2010
Location: Allen, TX
Posts: 996
Quote:
Originally Posted by shootnjunky View Post
I had the clutch die thing happen and then I replaced the pcv and itís been fine
clutch die thing?
__________________
1990 325is
m52b28
3.73lsd
1987 325is 5spd tranny
TeXJ is offline   Reply With Quote
Old 04-01-2018, 01:30 PM   #40
shootnjunky
E30 Addict
 
Join Date: Aug 2014
Location: ohio
Posts: 421
"Also, at times, just as I put the clutch in to go to neutral, it will die"

^this
shootnjunky is offline   Reply With Quote
Old 04-01-2018, 05:49 PM   #41
TeXJ
E30 Modder
 
Join Date: Apr 2010
Location: Allen, TX
Posts: 996
Quote:
Originally Posted by shootnjunky View Post
"Also, at times, just as I put the clutch in to go to neutral, it will die"

^this
aww ok, yeah that's what mine does
__________________
1990 325is
m52b28
3.73lsd
1987 325is 5spd tranny
TeXJ is offline   Reply With Quote
Old 04-02-2018, 05:44 AM   #42
jhaurimn
R3VLimited
 
Join Date: Nov 2012
Location: Minnesota
Posts: 2,146
Quote:
Originally Posted by 2mAn View Post
Well, you’re getting there. I’d start with a new o2 just as a precautionary and maintenance item and work from there. Chip should be easy to swap if you know someone who also has a similar setup.... hopefully it’s not the Harness. Is it fully modified or do you have an adapter...

I just had a random idea. Since you’re in MN, if the o2 doesn’t do anything and it appears to be electrical have you considered upgrading to a OBD2 setup with all the BS deleted from it? Better diagnostics should another issue arise
Modified harness. Have definitely considered new harness with adapter and or going obd2.

I have tried a different ecu, both with my trm chip and stock chip.

Going to unplug the o2 and see if there are any changes. I will be doing vanos seals once it gets warmer.
__________________
Current:
1989 325i
1988 M3
Past:
2001 330ci
2001 M3

Last edited by jhaurimn; 04-02-2018 at 06:05 AM.
jhaurimn is offline   Reply With Quote
Old 04-02-2018, 03:15 PM   #43
jhaurimn
R3VLimited
 
Join Date: Nov 2012
Location: Minnesota
Posts: 2,146
I seemed to have fixed my idle bouncing issue.

I had replaced my icv with a used oem one on ebay to eliminate that as a cause of my power issues. It did not fix my power issues however I believe thats when my idle bouncing issues started.

Heres what I did (in order) that led to my idle issues getting better (at least for now its better)

-I had swapped back to my old icv after realizing nothing was wrong with it
-I took the seal off my oil fill cap, cleaned the gasket, and flipped it upside down to make sure there wasnt a vacuum leak there

After this, I was still having the issues until I reset my ecu and it re-learned idle. Now my idle is lower, and the idle does not bounce anymore coming to a stop.

Still having major power issues tho.
__________________
Current:
1989 325i
1988 M3
Past:
2001 330ci
2001 M3
jhaurimn is offline   Reply With Quote
Old 04-02-2018, 03:40 PM   #44
TeXJ
E30 Modder
 
Join Date: Apr 2010
Location: Allen, TX
Posts: 996
you reset the ecu by holding the negative and positive cables together?
__________________
1990 325is
m52b28
3.73lsd
1987 325is 5spd tranny
TeXJ is offline   Reply With Quote
Old 04-03-2018, 05:46 AM   #45
jhaurimn
R3VLimited
 
Join Date: Nov 2012
Location: Minnesota
Posts: 2,146
Quote:
Originally Posted by TeXJ View Post
you reset the ecu by holding the negative and positive cables together?
I just took the negative cable off the battery for about 30 seconds.
__________________
Current:
1989 325i
1988 M3
Past:
2001 330ci
2001 M3
jhaurimn is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 03:11 PM.


Powered by vBulletin® Version 3.8.10
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Copyright 2004 - 2020 R3VLimited LLC