R3VLimited Forums

Go Back   R3VLimited Forums > E30 Technical Forums > Engine & Drivetrain > Forced Induction

Reply
 
Thread Tools Search this Thread
Old 04-15-2019, 09:04 PM   #31
nando
Moderator
 
nando's Avatar
 
Join Date: Nov 2003
Location: bellingham, wa
Posts: 33,706
It shouldn't leak (that would cause vac leak since it's past the AFM, turbo or not), but of course, if yours is stock and 30 years old, well.. anything could happen.

It sucks they cost so much now. I guess I was "lucky" that mine died long enough ago that I could afford to buy a new one, but not so long enough ago that it is completely worn out.

If you're running MS of course anything could work. Any 2 or 3 wire PWM IAC would be fine - BMW used them until the Valvetronic engines, which don't need an IAC because they don't use the throttle plate. Or anything from GM, Ford, etc.

Hyundai and Kia actually copy a lot of designs from the Germans, so that's another possible source. The former lead engineer of BMW Motorsports works there now (in case you didn't already know, hah!).

Funny thing about the GM stepper IACs. It's been ages since I've looked at, much less updated my Megasquirt 3 (since at least 2012), but last time I was looking at that stuff, they weren't reliable because the control mechanism couldn't track the position accurately enough, so they would "drift" out of synch. And also the hardware wasn't always good enough so it would overheat. I presume that's all solved now.

My cold idle actually sucks. It holds an "idle", but by that I mean it doesn't actually die - it's not smooth or steady. It's actually really obnoxious, it bounces up and down 500-1500rpm for at least 5 minutes before settling, ugh. But I drive the E30 so rarely now, and I have no intentions of keeping my current M20/Megasquirt, I just haven't bothered to even try to fix it.. it runs and drives just fine once it's warm. I try not to fix what isn't already broken...

Quote:
Originally Posted by e30davie View Post
Since mine was L- Jet M20b23 i didn't have an idle control valve. I used one from an AU Ford Falcon. Not really sure if you have the engine in the states. Not the neatest looking, but the valve cost me zero dollars from the wreckers and works perfect with the MS2 on closed loop. This way i didn't need to get a different rubber intake boot. Also im not sure the m20b25 intake boot would fit.
I agree, it's not very pretty

But I appreciate that it works, and it cost you nothing. It's like my COP setup - yeah I had to buy the MS3 setup and wire it etc. But the plugs, coils, wires, etc. were dirt cheap (GM stuff) and in those cases, they are miles ahead of the Germans. Who ever heard of a GM LStruck coil failing? Nobody. I had a misconfigured MSQ, that caused the coils to overheat enough that it melted the connectors, plugs and wires to the coils. But those coils are still going strong 8 years later, and I have no idea how old they were when I bought them. Some BMW coils barely last 5 years...
__________________
Build thread

Bimmerlabs

Last edited by nando; 04-15-2019 at 09:10 PM.
nando is offline   Reply With Quote
Old 04-16-2019, 02:12 AM   #32
e30davie
E30 Enthusiast
 
Join Date: Apr 2016
Location: Australia
Posts: 1,129
Quote:
Originally Posted by nando View Post

I agree, it's not very pretty

But I appreciate that it works, and it cost you nothing. It's like my COP setup - yeah I had to buy the MS3 setup and wire it etc. But the plugs, coils, wires, etc. were dirt cheap (GM stuff) and in those cases, they are miles ahead of the Germans. Who ever heard of a GM LStruck coil failing? Nobody. I had a misconfigured MSQ, that caused the coils to overheat enough that it melted the connectors, plugs and wires to the coils. But those coils are still going strong 8 years later, and I have no idea how old they were when I bought them. Some BMW coils barely last 5 years...
If you appreciate that, you are going to love the other dodgy shit in my engine bay. I too bought 8 x LS1 coils, for $60 aud ($42usd?) found some aluminium and threaded rod in the shed and run these off the LEDs on the MS2. I also manged to overheat them with the incorrect dwell settings. not quite 8 years but a few thousand kilometers. The last distributor rotor i bought was over $100 aud...

photos attached.
Attached Images
File Type: jpg e30coil1.jpg (104.9 KB, 13 views)
File Type: jpg e30coil2.jpg (119.3 KB, 14 views)

Last edited by e30davie; 04-16-2019 at 02:44 AM.
e30davie is offline   Reply With Quote
Old 04-16-2019, 09:04 AM   #33
LowR3V'in
No R3VLimiter
 
Join Date: Feb 2004
Location: WestSide
Posts: 3,777
Send a message via AIM to LowR3V'in
^ i am also running my coils in wasted spark from the LED. is that actually dodgy though?
__________________
LowR3V'in is offline   Reply With Quote
Old 04-16-2019, 02:57 PM   #34
e30davie
E30 Enthusiast
 
Join Date: Apr 2016
Location: Australia
Posts: 1,129
I was more refereeing to the fact that mine are cable tied to the AC hoses behind the headlight.

Last edited by e30davie; 04-16-2019 at 04:03 PM.
e30davie is offline   Reply With Quote
Old 04-16-2019, 09:36 PM   #35
nando
Moderator
 
nando's Avatar
 
Join Date: Nov 2003
Location: bellingham, wa
Posts: 33,706
Quote:
Originally Posted by LowR3V'in View Post
^ i am also running my coils in wasted spark from the LED. is that actually dodgy though?
nah it's fine.

LS1 coils are a little different, but something to know about the LS2 truck coils - they will auto-ignite if you overdwell them. This leads to higher ignition advance than you expect. Basically, keep them under 2ms.
__________________
Build thread

Bimmerlabs
nando is offline   Reply With Quote
Old 04-17-2019, 07:58 AM   #36
tschultz
Grease Monkey
 
tschultz's Avatar
 
Join Date: Jun 2013
Location: CO
Posts: 319
With 42#'s on my M30, I was idling at 1.3ms and having some strange behavior near idle. I went to 30#'s and idle around 2ms now. This is at 5300 ft.

I did soem testing on the subject:


I am approximately 300hp when corrected for altitude, but my max boost is at 160kpa and the 30#'s are just over 80% duty cycle at higher rpm's and boost.

This is where i'm at with altitude corrections based on real world testing, but still a work in progress.

__________________
http://www.Drive4Corners.com
tschultz is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 01:10 PM.


Powered by vBulletin® Version 3.8.10
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2004 - 2020 R3VLimited LLC