Announcement

Collapse
No announcement yet.

S52/ZF320 Driveline Vibrations

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    If you think that adjusting the engine/trans mounts is changing the vibration, then I would measure the driveline angles. I have done it several times on various vehicles. You want everything in 'phase' from looking at it from the side as in the attached picture as well as the top down (engine and rear axle are straight and square in the frame).

    Click image for larger version

Name:	driveline_angle.jpg
Views:	50
Size:	20.4 KB
ID:	9994291

    Comment


      #17
      Both of the U joints are on the rear half of the driveshaft. Does this mean I need to change the angle behind the CSB or of the transmission output shaft? I will get under there and try to measure the angles a few more times, but I am unsure of which components to match the angles of

      Comment


        #18
        The angles on the u joints should be in the same phase (because there are two). If you can, take readings off the u joints, a part that is flat as the joint cap. I am not expecting a solution here, but its a place to look and determine of there is a larger problem. Also see if the diff pinion input has any play.

        Comment


          #19
          I finally got time to take a look at the angles and this is what i found using a phone angle app. The first time around I found that the trans/front half was 87.1* the back half was 86.4* and the rear half was at 88.9*. These measurements were from the passenger side. This results in a 1.2* of operation for the front U-Joint and 2.5* of operation for the rear U-Joint. The second time was taken from the drivers side, similar to the picture jbontke posted. I found the front to be ~95.8-95.9* the back half to be ~97.1* and the diff was at ~94.9-95*. This results in ~1.3* for the front U-Joint and ~2.1-2.2* for the rear U-Joint.

          I checked the pinion gear for play and it was good when i pulled on it in/out and up/down.

          I tried jacking the trans up to decrease the angle of the front half of the driveshaft, but it did not change by more than 0.2-0.3*. I did not loosen any of the bolts or the nut holding the splines, so i think this may be the issue. I also noticed the guibo was flexing a lot when i jacked the transmission up.

          My next question would be should i change the diff angle or the trans angle to get the U-Joint operating angles closer to the same angle?

          Comment


            #20
            I read that less than 4 degrees is acceptable. I would not be concerned with your angles. The pinion will move up under hard acceleration increasing the angle. I set my cars to match the trans (single driveshaft). On drag cars, they will set the pinion angle down more because at the axle is loaded, the pinion rises making the angle to the trans equal (not necessary for street cars). I wonder if the rear diff is moving a lot under hard acceleration knocking out the alignment of the driveshaft? Then when the rear diff is it not under load, drive shaft alignment returns to normal. This has to be very frustrating.

            Comment


              #21
              Originally posted by jbontke View Post
              I read that less than 4 degrees is acceptable. I would not be concerned with your angles. The pinion will move up under hard acceleration increasing the angle. I set my cars to match the trans (single driveshaft). On drag cars, they will set the pinion angle down more because at the axle is loaded, the pinion rises making the angle to the trans equal (not necessary for street cars). I wonder if the rear diff is moving a lot under hard acceleration knocking out the alignment of the driveshaft? Then when the rear diff is it not under load, drive shaft alignment returns to normal. This has to be very frustrating.
              It is quite frustrating. The revshift mounts came in today and they are slightly taller than the garagistic mounts (~1.25" vs 1.35"). This shudder happened before and after i replaced the subframe mounts with 80a mounts.

              I was under the impression that in order to cancel out the acceleration/deceleration of the U-joints, the different in operating angle between the front and rear U-Joint should be less than 0.5*. I have also heard that the maximum acceptable operating angle for a single U-Joint should be less than 5 degrees, but have heard people throw other numbers out there.

              I am going to install the revshift mounts, loosen all of the mounts then retighten everything. I will measure the angles of all of the components again and see if they get closer. I really am at a loss with what to do

              Comment


                #22
                Finally got around to swapping the mounts. Almost no more shuddering on deceleration. It still does it when I hit the brakes decently hard when in gear. It did get rid of the almost constant rumble that i associated with all 80a mounts and a stiff suspension.

                Some things i noticed were that the garagistic mounts were ~0.1" shorter and compressed another 1/16"-1/8" under the weight of the trans. The garagistic mounts were permanently changing shape under the weight of the trans. The revshift mounts (more OEM like) centered the trans ears in the studs better and prevented the trans from being off center.

                I noticed the guibo was flexing bad when i swapped the mounts so i loosened the collar nut and lengthened the drive shaft to reduce the flexing. I can't visually see flexing anymore, and I tightened it as much as i could by hand instead of using a tool to tighten it.

                Because of this change the angles were ~96* for the engine(Hard to measure), ~96.3* for the front shaft and ~95.5* for the diff. I think I need to shim it around to get the guibo to flex a little less and the pinion angle a little closer to the front shaft.
                Last edited by cdl723; 04-26-2021, 10:36 AM.

                Comment


                  #23
                  Originally posted by cdl723 View Post
                  Almost no more shuddering on deceleration. It still does it when I hit the brakes decently hard when in gear.
                  So you still hear the clang noise on hard breaking in gear? I wonder if this means that the rear subframe is moving under braking causing an issue...

                  Comment


                    #24
                    Originally posted by jbontke View Post

                    So you still hear the clang noise on hard breaking in gear? I wonder if this means that the rear subframe is moving under braking causing an issue...
                    Its more of a light shudder under hard braking, but still feels driveline related. It doesn't do it with the clutch pressed. I just received the parts to refresh the brakes all around and see if that remedies that noise that was heard in the video. I can hear that same noise when im driving buildings on my passenger side, but cant hear it outside of that. Chances are its a parking brake thats catching slightly. One of the shoes had the lining material fall off when i was doing the subframe bushings a few weeks ago and then the noise started.

                    Now that im thinking about it acceleration would cause the pinion angle to increase while braking/decel would cause it to decrease slightly when compared to a static situation. I wonder if the trans mounts were just a small bandaid and if shimming the diff is the answer.
                    Last edited by cdl723; 04-26-2021, 01:55 PM.

                    Comment

                    Working...
                    X