Announcement

Collapse
No announcement yet.

MS3x on m52-Do i need to mess with internal jumpers?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    MS3x on m52-Do i need to mess with internal jumpers?

    Hey Everyone. I am hoping to test fire my car this week. I have an m52 b28 in my car, running the obd2 harness spliced to my MS3x harnesses. Full sequential COP and injection. I have the m50 cam position sensor installed as form my understanding this is the one megasquirt can read, and I have an m44 crank sensor installed.


    The only thing I am a bit confused about right now is if I need to mess with any of the jumpers on the board. The manual lists jumpers in several places, but I honestly don't know which ones/in what scenarios I need them. The manual is pretty all encompassing, and this can get kind of confusing at times.

    #2
    If a crank/cam sensor has 2 wires, use the VR circuit. If it has 3, use the Hall circuit.

    You do however need to address running the PWM idle valve, depending on how you have it setup.

    If your injectors are high impedance, they should be fine and not require anything.
    '84 318i M10B18 147- Safari Beige
    NA: 93whp/90ftlbs, MS2E w/ LC, 2-Step
    Turbo: ?whp/?ftlbs, MS3x flex @ 17psi

    Comment


      #3
      You need to use the pull-up jumper for cam signal. And also the pull up jumper to enable tacho output. And also add pull-up resistor for crank signal too. 1k is ok. And btw. you could have used stock m52 crank sensor too. Cam sensor only needs to be swapped. And make sure it's m50 vanos version which is hall. And ypu can use the better cam triggering mode.

      And megasquirt manual is really clear. You just need to know your engine very well and have some basic electronic knowledge :D
      Last edited by pazi88; 12-20-2018, 05:28 AM.

      Comment


        #4
        The manual may be clear enough, but it specifically calls out parts for LSx motors, Nissan motors, etc. The hard part is the internet is full of incorrect information. Try and search specifically for what type of cam and crank sensor the m5x motors have and you will get EVERY answer under the sun...

        Also, I really need to have someone help me understand why I would need to add a resistor inline for the crank sensor. I have seen people install without, and some with and cannot find a clear reason either way as to why. Also, I purchased the m44 crank sensor since the obd2 harness I have somehow doesn't mate with the stock obd2 m52 crank sensor on the motor? Both ends have female connectors...

        Comment


          #5
          also, the manual specifically states to not use the jumper for the cam input for hall sensor.
          Attached Files

          Comment


            #6
            Originally posted by haaken675 View Post
            also, the manual specifically states to not use the jumper for the cam input for hall sensor.
            ... while adjusting the potentiometers ;)

            The need for pull-up resistor for hall sensor depends if the sensor has one built in. This can be easily checked by powering the hall sensor and checking if the signal output raises to 5v or not. If it does, you need pull-up resistor. No need to rely on information from internet. And why that pull-up is inportant is that ecu input just senses if the input is 0v or 5v. The bmw hall sensors only ground the signsl wire when it senses the tooth. But there is nothing that raises the volt level at signal wire to 5v when it doesn't sense tooth. So you need to add for example add that 1k resistor to "pull up" the line voltage to 5v in that situation.
            Last edited by pazi88; 12-20-2018, 08:49 AM.

            Comment


              #7
              and this is again where this is starting o not make sense...

              a) it does not say anywhere in the manual to put the jumper back after adjusting the potentiometer, and it only kists adjusting them while powered as an "option" With no power, adjusting a potentiometer with art of the board jumped or not doesn't make a difference.

              b) Also, if I have 5v reference coming out of the ecu and going to my hall sensor, why would I then need to pull up the signal back to 5v? I ask this in all seriousness because I don't see there being an issue unless the sensor had a ton of resistance in it, and in that case, why would I add more resistance to it?

              Comment


                #8
                The manual says that the jp7 jumper enables the cam signal pull-up resistor. And in different part of the manual it's described on when and why you need it. I think that's quite clear.

                And the 5v is to power on the hall sensor. Which is only capable of grounding signal wire when the sensor sees tooth (google open collector output). It's not switch that changes the output wire between ground and 5v. Some hall sensors have built in pull up resistor for signal wire. But bmw hall sensors generally don't.

                As I said before. General electronics knowledge is needed when doing tvis kind of thing. If you don't have it, internet is full of educational stuff that is worth spending few evenings at least.
                Last edited by pazi88; 12-20-2018, 09:46 AM.

                Comment


                  #9
                  Originally posted by Jaxx_ View Post
                  You do however need to address running the PWM idle valve, depending on how you have it setup.
                  From my understanding, you can use both the idle and Fidle circuits to run the icv. That is how I have it wired currently. Am I missing something more to this then the configuration in the software?

                  Comment


                    #10
                    Originally posted by haaken675 View Post
                    From my understanding, you can use both the idle and Fidle circuits to run the icv. That is how I have it wired currently. Am I missing something more to this then the configuration in the software?
                    Yes you can. But unfortunately the output current capability of the fidle ouput is very poor and it can burn when using bmw icv. You can do the 2wire pwm mod to it to increase current capability. But that is bit wasted effort becsuse you can use other unused outports. I personally used inj1 output on the magesquirt pcb because that can drive higher loads.

                    Comment


                      #11
                      This is turning out to be more of a pain then I originally anticipated. Wishing at this point I just swapped out my obd2 harness for an odd1 harness and shelled out the money for the mspnp unit at this point.

                      If I pull my harness back apart, and it looks like om going to have to at this point, I can swap out the Fidle wire for injector 1 output and keep the idle output? I haven't even got this far yet, but will tunerstudio fight me on using the injector 1 output for the ICV?

                      It looks like it would have just been so much simpler to have created a wire loom from scratch instead of this piecemeal harness (e30 c101 spliced into m52 obd2 harness spliced into ms3x harness) when my car is gutted, I do not have a stock gauge cluster and will be viewing everything from tach to speedometer readings through tunerstudio on a raspberry pi dash...


                      At this point, if I rewire my ICV and add a resistor in for the cam sensor, am I missing anything else? I already went back onto the board and put the jp7 jumper back.

                      Comment


                        #12
                        You can check from tunerstudio which outputs are available for each function. But that injector output1 works.

                        And there isn't much that you need to do anymore. Just swap wire from fidle to inj1 or 2, install jp7 jumper and put 1k resistor inside megasquirt from 5v output in proto area to some point where crank signal is. I think there was instructions for this in the manual.

                        And make sure to use the inj 1 or 2 from main megasquirt pcb. Not from ms3x card where you have wired actual injectors :D

                        Comment


                          #13
                          I ordered an external resistor to our online, hopefully that works as well as putting one on the board itself. I don’t trust myself to solder on the board itself despite having done some soldering.

                          Hopefully once I make these changes I can get the car fired up after Christmas.

                          Comment


                            #14
                            Originally posted by haaken675 View Post
                            From my understanding, you can use both the idle and Fidle circuits to run the icv. That is how I have it wired currently. Am I missing something more to this then the configuration in the software?
                            This is correct, but I believe you need to hookup a flyback wire. I have mine setup the same way, and I recall having to setup a flyback wire from the X board to the main board. I forget the specifics, but it's all in the manual.

                            I believe it to be ideal to run the icv in the native form, with 2 PWM wires and 1 power wire. I don't know the speed of it in 2 wire mode, but it does work.


                            I think you did the right thing doing the ms3x instead of pnp. You'll be proud of your accomplishment when you get it running.
                            '84 318i M10B18 147- Safari Beige
                            NA: 93whp/90ftlbs, MS2E w/ LC, 2-Step
                            Turbo: ?whp/?ftlbs, MS3x flex @ 17psi

                            Comment


                              #15
                              I think some of my confusion has come from the fact that I just realized that depending on which computer I have been using, I have different versions of the megasquirt manual on them somehow...

                              Anyways, is this the best route for the ICV wiring? I'm willing to try this vs taking my harness apart as it doesn't look too difficult to accomplish.
                              Attached Files

                              Comment

                              Working...
                              X