Announcement

Collapse
No announcement yet.

'84 318i running problems

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    '84 318i running problems

    Trying to help out my father who is out of state with his e30. Car is an '84 318 and problem is that the car starts up but then will almost immediately die. He has replaced:

    Fuel pump
    Fuel filter
    Injectors
    Thermo-time switch

    He also cleaned the ICV and checked for vacuum leaks. Any ideas as to what might be going on? Thanks in advance-
    '90 325is/S52
    '76 2002
    '74 2002tii
    '06 325i sedan
    '05 X5 3.0i
    '86 Alfa Spider Veloce

    #2
    Does it lose spark when it dies? Fuel pressure? Any other problems that existed before this particular issue? How was the vacuum leak test performed?

    IMG_0145 by Jonathan Martin, on Flickr

    Comment


      #3
      I don't think it is losing spark. It stumbles some and then dies. Fuel pressure has not been tested yet. I think he waited on that since he just put a new pump in. No other issues prior that I'm aware of. He searched for vacuum leaks by spraying carb cleaner around lines and at intake, etc.
      '90 325is/S52
      '76 2002
      '74 2002tii
      '06 325i sedan
      '05 X5 3.0i
      '86 Alfa Spider Veloce

      Comment


        #4
        Either losing spark or fuel. Is it possible the engine is only getting fuel from the cold start valve, but not the injectors?

        Comment


          #5
          Originally posted by Sunnyledge View Post
          Either losing spark or fuel. Is it possible the engine is only getting fuel from the cold start valve, but not the injectors?
          That's a great question. Apparently the car will not even start anymore now. It turns over quickly but does not start. When I asked him to remove a plug and look, he did say there was fuel on the end of the plug, although not in a 'flooded' sense.
          '90 325is/S52
          '76 2002
          '74 2002tii
          '06 325i sedan
          '05 X5 3.0i
          '86 Alfa Spider Veloce

          Comment


            #6
            Which injectors did he change, there is a cold start one int he manifold but that one probably isn't necessary? Which pump did he change, lift or external? Did he check if he was getting spark coming off of all 4 wires?

            Comment


              #7
              So did you figure it out?
              1984 318i Coupe 66k Auto. Status: Non-Operational
              Looking for help getting it to run in the bay area!

              Comment

              Working...
              X