Announcement

Collapse
No announcement yet.

M42 won't start

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    M42 won't start

    So after work I went to start up the car and it just kept cranking.

    -Fuel pump IS working (should as it's fairly new from the dealer).
    -All fuses are intact.
    -Coils have <10k miles on them.

    Any ideas? I'm hoping to replace the Crankshaft Postion Sensor this evening.
    Originally posted by Gruelius
    and i do not know what bugg brakes are.

    #2
    ICV or TPS or try M42club.com

    Comment


      #3
      ICV is fairly new from the dealer

      I'll check the TPS too
      Originally posted by Gruelius
      and i do not know what bugg brakes are.

      Comment


        #4
        OHM out the CPS.

        ICV isn't going to prevent a start, nor will the TPS.

        E30 ABS Pump Refurbishment Service
        https://mtechniqueauto.com/

        Comment


          #5
          my old 318i left me stranded and i found out that it was the ECU(brain) it was not programing engine to inject fuel, and those coil should not be a problem, check for spark and the usual trouleshooting

          Comment


            #6
            Was it working fine before, or are you trying to start a car that you've never seen running?

            Originally posted by whysimon
            WTF is hello Kitty (I'm 28 with no kids and I don't have cable)

            Comment


              #7
              Originally posted by FredK View Post
              Was it working fine before, or are you trying to start a car that you've never seen running?
              At the breakfast his car was running quite well
              Last edited by restoration; 10-10-2007, 07:34 PM.

              Comment


                #8
                Does it even try to start [sputter, hickup]?


                Originally posted by vlad
                Do you know anybody else who built that many bad ass E30s?

                Comment


                  #9
                  I'll try and swap ECUs too.

                  Yes, the car ran perfectly that morning.
                  Originally posted by Gruelius
                  and i do not know what bugg brakes are.

                  Comment


                    #10
                    Originally posted by Joe318is View Post
                    Does it even try to start [sputter, hickup]?

                    No, just cranks and cranks.
                    Originally posted by Gruelius
                    and i do not know what bugg brakes are.

                    Comment


                      #11
                      Originally posted by Jordan View Post
                      OHM out the CPS.
                      It's going to be dark and cold. I'm just going to swap it.

                      Originally posted by Jordan
                      ICV isn't going to prevent a start, nor will the TPS.
                      Yeah, i didn't figure either of them would prevent it from actually starting up.


                      What about the cold start valve? Do M42s have them? Or would a faulty one just prevent it from starting up right away?
                      Originally posted by Gruelius
                      and i do not know what bugg brakes are.

                      Comment


                        #12
                        getting fuel to the engine? recently put a chip in it?
                        sigpic

                        Comment


                          #13
                          One thing ive heard people complain about had been the crank ref sensor. ive never had an issue with it before [my m42 hasnt acted up in 50k and 4.5 years]

                          Its on the drivers side [i think] one lead going in, looks like a little black barrel. It could be gunked up, loose, or broken.


                          Originally posted by vlad
                          Do you know anybody else who built that many bad ass E30s?

                          Comment


                            #14
                            Originally posted by E30 Groupie View Post
                            getting fuel to the engine? recently put a chip in it?

                            The fuel pump is working, I can only assume that it's getting fuel.

                            Haven't touched the ECU at all.
                            Originally posted by Gruelius
                            and i do not know what bugg brakes are.

                            Comment


                              #15
                              Fuel pump working doesnt mean its getting fuel. if the injectors are not firing, which would be a fuel management issue [sensors, ecu, etc.] then there is no fuel being delivered into the cylinder.


                              Originally posted by vlad
                              Do you know anybody else who built that many bad ass E30s?

                              Comment

                              Working...
                              X