Announcement

Collapse
No announcement yet.

Can't push hood closed

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Can't push hood closed

    SO for some reason I can't close the hood on my e30. Not, it own't latch, it doesn't even get to that point. I fold it down, but then I can't push it down/forward to the latch. The slider things are lined up with the rails at the firewall fine, but it like the front mechanism is locked in place. I can fold it up and down just fine, but pushing into the closed position is totally jammed.

    I'm not exactly sure how the whole mechanism works in the front, so I'm not sure how to troubleshoot it. I tried spraying some PTFE spray onto it but that didn't help. Just not a blasted it all with some PB Blaster, and I'm lettign it sit and will try in a bit and see if that helps.

    Anyone have any ideas?
    2002 530i - Daily
    2013 Ford Flex Ecoboost - wifes/family hauler
    1986 325es - fun car (or money pit depending on who you ask)

    My build thread - https://www.r3vlimited.com/board/sho...d.php?t=422370

    #2
    Blasted everything with PB Blaster and let it soak for an hour or so. Went back and it still won't budge. I'm at a loss, I really hope someone knows a trick to fix this.
    2002 530i - Daily
    2013 Ford Flex Ecoboost - wifes/family hauler
    1986 325es - fun car (or money pit depending on who you ask)

    My build thread - https://www.r3vlimited.com/board/sho...d.php?t=422370

    Comment


      #3
      Have you tried disconnecting the lift support arm? Looking at my hood this morning, the lift support arm looks like it could jam????
      2004 525i Manual - 1985 325E Coupe Manual

      Comment


        #4
        Your hood is connected to a round metal tube with a metal rod inserted. The rod is rusted and fused to this round tube. You will need to spray a lot of PB blaster into this tube and use a small hammer to gently knock the outside of the tube to break the rust loose. Be patience, you'll need to spend some time to do this. If that does not work, then you will have to remove the hood then try to break the rod free.
        Last edited by dnguyen1963; 10-10-2019, 06:54 AM.

        Comment


          #5
          Well, this is weird, it was the passenger fender, or rather the lack of it. I had it off because I was swapping it with an un-dented one, but took longer to paint it than I was thinking. As soon as I put the fender back on, hood closes no problem.

          I assume it has something to do with the support arm, since it is on that side. Perhaps when the fender isn't there the arm bends outwards and binds up, thus not closing? But with the fender in place it is allowed to do that. At least thats' my guess.
          2002 530i - Daily
          2013 Ford Flex Ecoboost - wifes/family hauler
          1986 325es - fun car (or money pit depending on who you ask)

          My build thread - https://www.r3vlimited.com/board/sho...d.php?t=422370

          Comment

          Working...
          X