Announcement

Collapse
No announcement yet.

Engine running rough

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Engine running rough

    Hello,

    My engine has seemed to lose performance over time and has recently started idling very roughly. I have stopped driving it since and want to figure out what is wrong. Here's a youtube video of the idle: https://www.youtube.com/watch?v=zc9YYO6K8DU

    O2 sensor, TPS, injectors have been replaced in the last 2 years.

    #2
    Have you done any diagnostic work at all? That idle could be caused by quite a few items, and we won't be able to help you if you don't start to narrow down the possibilities.

    Remember, just because a component was recently replaced does not mean it is not at fault.

    Comment


      #3
      I would start by removing the spark plugs and see if any are fouled. Then a compression test. Check all the vacuum and intake hoses are not cracked. When was the timing belt changed?
      2004 525i Manual - 1985 325E Coupe Manual

      Comment


        #4
        Check the intake L boot. Those tend to develop cracks that worsen over time and will allow unmetered air to enter the intake causing rough idle and poor performance. The engine flex and vibration causes these older intake boots to crack open. Inspect it carefully and you will see micro cracks all over ....


        https://www.youtube.com/watch?v=fZiTHMTZH7M

        Comment


          #5
          it could be what i experienced... the mufller started to fall apart from inside and was clogging up. i was taking mine off to remove subframe and about 2 lbs of crap came out of it. I tried starting with no exhaust, and it idled just fine. Something to look at. I was chasing this rough idle for a while now.

          Comment

          Working...
          X