Announcement

Collapse
No announcement yet.

Free VIN Check Vehicle History Report - Autocheck

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • gath
    replied
    Dang! this is amazing. Thnx, both checked out fine and am the 2nd owner to both.

    Leave a comment:


  • Anguz
    replied
    shiit my original motor (blown) had around 300k, and im the 6th owner.

    Leave a comment:


  • themoonman
    replied
    Thanks worked great!
    i guess im the 4th owner and my car has 225k, my odometer has stopped working at 190k so this is news to me.
    the m20 is running like a champ too!

    Leave a comment:


  • TurboJake
    replied
    Originally posted by smooth View Post
    oh you owned it while it was doing that? hahaha, I dunno maybe someone was using your old plates then :D
    Yeah.
    That's the only thing I can really think of. that someone renewed the plates and hadn't switched them to another car or something.

    I can think of other more illegal and sinister things though too. I'm just hoping it's what I just said.

    Leave a comment:


  • smooth
    replied
    oh you owned it while it was doing that? hahaha, I dunno maybe someone was using your old plates then :D

    Leave a comment:


  • TurboJake
    replied
    Originally posted by smooth View Post
    could be anything

    change of address before actually moving and then having to smog while still living in utah
    moving to WI but smogging back home after a fail to keep tags until it could be addressed
    or more likely you have someone divorcing and moving to WI and then changing title back in Utah to remove the second owner/ex-spouse
    Neither.

    I bought the car in 10/2010 and registered it here in 10/2010. I've never lived in Utah. I just flew out there to drive it home. So it's registration was renewed in UT, 4 months after it was titled in my woman's name.

    Leave a comment:


  • e30trooper
    replied
    Thanks!
    Last edited by e30trooper; 03-06-2012, 01:39 AM.

    Leave a comment:


  • smooth
    replied
    could be anything

    change of address before actually moving and then having to smog while still living in utah
    moving to WI but smogging back home after a fail to keep tags until it could be addressed
    or more likely you have someone divorcing and moving to WI and then changing title back in Utah to remove the second owner/ex-spouse

    Leave a comment:


  • Stanley Rockafella
    replied
    aWESOMENESS!!

    Leave a comment:


  • Robert
    replied
    cant figure it out.

    Leave a comment:


  • TurboJake
    replied
    03/10/2010 SALT LAKE CITY, UT
    Motor Vehicle Dept. EXCLUDED/EXEMPT
    03/31/2010 SALT LAKE CITY, UT
    Motor Vehicle Dept. REGISTRATION EVENT/RENEWAL
    10/04/2010 WAUSAU, WI
    Motor Vehicle Dept. TITLE (Title #:10277M%%%%%)
    REGISTRATION EVENT/RENEWAL
    EXCLUDED/EXEMPT
    02/01/2011 SALT LAKE CITY, UT
    Motor Vehicle Dept. REGISTRATION EVENT/RENEWAL
    EXCLUDED/EXEMPT
    10/04/2011 WAUSAU, WI
    Motor Vehicle Dept. REGISTRATION EVENT/RENEWAL
    EXCLUDED/EXEMPT


    Interesting.... Kinda curious as to why was the registration associated with this car renewed in Utah 3 months after bringing it back to WI..

    Might have to keep an eye on that.

    EDIT: The S12 got a score of 2
    :rofl:
    Last edited by TurboJake; 03-06-2012, 01:16 AM.

    Leave a comment:


  • Zasz
    replied

    Leave a comment:


  • firefirefire90
    replied
    damn, my car failed emissions 7 times in 2010

    Leave a comment:


  • livetheride
    replied
    Awesome! works! I'm only the third =)

    Leave a comment:


  • ButtJuice
    replied
    Awesome! .... wow. I'm the 7th owner. :(
    Last edited by ButtJuice; 03-05-2012, 11:58 PM.

    Leave a comment:

Working...
X