Announcement

Collapse
No announcement yet.

Central Locking Gremlin

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Central Locking Gremlin

    About a week or so ago, for no apparent reason, my central locking started to go crazy. Now, whenever I hit even a slight bump, all the doors lock. I'll admit I haven't even begun to search for it, mainly because I know nothing about electrical stuff, but also because I was hoping someone here could point me in the right direction.

    Thanks!

    Originally posted by SpasticDwarf
    Honestly I built it just to have a place to sit and listen to Hotline Bling on repeat.

    #2
    Nothing?

    For the record, what I meant by "I'll admit I haven't even begun to search for it" is that I haven't started to take my car apart to look for it because I have no fuckin' clue what to look for. Of course, I searched r3v and found nothing similar to my issue...

    Originally posted by SpasticDwarf
    Honestly I built it just to have a place to sit and listen to Hotline Bling on repeat.

    Comment


      #3
      I'd start with swapping the central lock control module from a different E30 and see if it still does that. Maybe a fellow E30 from your area can lend you one for 15 minutes. Or swap yours to another car and see if that car gets the same symptom. The module is located in the front right speaker hole. You need to remove the kick panel and speaker in order to get to it.

      If swapping the module didn't help, it could be one of the door/trunk actuators going bad. On the passenger side door, there's a separate micro-switch for locking. I'm suspecting that switch is the culprit. I'd start there after checking out the central lock module.
      90 E30 S50B30
      http://www.fquick.com/roadhazard/

      Comment


        #4
        Originally posted by RoadHazard View Post
        I'd start with swapping the central lock control module from a different E30 and see if it still does that. Maybe a fellow E30 from your area can lend you one for 15 minutes. Or swap yours to another car and see if that car gets the same symptom. The module is located in the front right speaker hole. You need to remove the kick panel and speaker in order to get to it.

        If swapping the module didn't help, it could be one of the door/trunk actuators going bad. On the passenger side door, there's a separate micro-switch for locking. I'm suspecting that switch is the culprit. I'd start there after checking out the central lock module.
        Cool! Thanks! Unfortunately there isn't anyone near me :\

        Originally posted by SpasticDwarf
        Honestly I built it just to have a place to sit and listen to Hotline Bling on repeat.

        Comment


          #5
          Sounds like a short. Like mentioned before, check the central locking module. I've seen a few for sale recently here
          sigpic
          Parts Wanted
          The Never-ending Resto Mod

          Comment


            #6
            I had a very similar problem. Driving around one day my locks would unlock/lock/unlock/lock on their own, and it ultimately stopped after a day or two.

            I thought for sure it was the module going bad so I swapped it out. No dice. I did some more digging and started inspecting the large electrical connection from the door to the body.

            The pin for constant power had started to back itself out of the connector, making contact sporadically...it finally worked itself out of the connector far enough where it was no longer making contact. I pushed the pin back in and my central locking returned to normal.

            Sounds like it could be the same problem, I'd give it a shot before taking out the speaker and module. Good luck, let us know how it goes!

            '91 318is - OBD-II S52 swapped - E30 M3 5-lug - 5x120 BBS RC090 (E39 Style 5) - TCK D/A coilovers 550/700 [SOLD]
            '87 535i - Vacuum brake conversion [SOLD]
            '93 525iT - 5-speed swap - 320k and counting
            '09 328xi - 6-speed

            Comment


              #7
              Originally posted by Gooch View Post
              I had a very similar problem. Driving around one day my locks would unlock/lock/unlock/lock on their own, and it ultimately stopped after a day or two.

              I thought for sure it was the module going bad so I swapped it out. No dice. I did some more digging and started inspecting the large electrical connection from the door to the body.

              The pin for constant power had started to back itself out of the connector, making contact sporadically...it finally worked itself out of the connector far enough where it was no longer making contact. I pushed the pin back in and my central locking returned to normal.

              Sounds like it could be the same problem, I'd give it a shot before taking out the speaker and module. Good luck, let us know how it goes!
              Awesome! I'll check that tomorrow. Thanks!

              Originally posted by SpasticDwarf
              Honestly I built it just to have a place to sit and listen to Hotline Bling on repeat.

              Comment


                #8
                Update?

                Comment


                  #9
                  Originally posted by dogsbark26 View Post
                  Update?
                  I haven't had a chance to check it with the school work that was dumped on me, but I'll definitely check it later today.

                  Originally posted by SpasticDwarf
                  Honestly I built it just to have a place to sit and listen to Hotline Bling on repeat.

                  Comment


                    #10
                    i would clean the contacts first with contact cleaner.
                    Your signature picture has been removed since it contained the Photobucket "upgrade your account" image.
                    ---------------------------------
                    89 E30 S52
                    ---------------------------------
                    Transaction Feedback.

                    Comment


                      #11
                      Well, that fixed it as far as I can tell.

                      Originally posted by bernzpeed View Post
                      i would clean the contacts first with contact cleaner.
                      I didn't hit it with contact cleaner but if it starts happening again I'll definitely pick some up.

                      Originally posted by SpasticDwarf
                      Honestly I built it just to have a place to sit and listen to Hotline Bling on repeat.

                      Comment


                        #12
                        What fixed it? You just fiddled with the door harness connector? Unplug and replug? Or what?

                        Comment

                        Working...
                        X