Announcement

Collapse
No announcement yet.

524 ECU Compatible with WAR CHIP?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    524 ECU Compatible with WAR CHIP?

    Anyone know if a 524 ECU will work with the MAF/WAR Chip? I'm a dummy and thought this whole time I had a 173, realized after I installed everything and was troubleshooting cuz the car idles great, revs great under no load, as soon as i try to drive tho, it stumbles after giving it gas...I double checked everything and seems to be hooked up correctly, the WAR Chip was set up with 173 tunes and a 173 chip.

    When i Unplug the maf, nothing happens, so I'm guessing its not responding...

    Any help would be great, especially since its a weekend :( Miller wont be open till monday. Hopefully Brody checks his work e-mail on Saturdays :) Haha.
    (SOLD) 1988 327i Build Thread: http://www.r3vlimited.com/board/showthread.php?t=155086
    1970 Gruppe 2 2902 M20 Turbo Build: http://www.r3vlimited.com/board/showthread.php?t=373891

    #2
    Looked thru my extra parts and I had a 173, same issues. Idles fine...revs if I accelerate slowly in neutral. Quick throttle = bog.

    I'm pretty confident my wiring is correct.
    http://i149.photobucket.com/albums/s...9/8554eeb3.mp4

    I know it's the same as the faulty wiring vid on YouTube. But could something else wrong make this happen as well?
    (SOLD) 1988 327i Build Thread: http://www.r3vlimited.com/board/showthread.php?t=155086
    1970 Gruppe 2 2902 M20 Turbo Build: http://www.r3vlimited.com/board/showthread.php?t=373891

    Comment


      #3
      So the MAF plug can be plugged in both ways,ale sure you look at the shape of the plug, there's a guide to know which way it goes, problem fixed
      (SOLD) 1988 327i Build Thread: http://www.r3vlimited.com/board/showthread.php?t=155086
      1970 Gruppe 2 2902 M20 Turbo Build: http://www.r3vlimited.com/board/showthread.php?t=373891

      Comment


        #4
        You plugged it in backwards. Hope you haven't fried the MAF yet. i can tell by the video when it zooms in on the MAF plug.

        EDIT: Some how I didn't see the problem fixed post. It will plug in both ways, one way is just VERY tight and should signify that something is wrong.

        Comment


          #5
          I hope I didn't either, I just e-mailed you some videos...of whats going on..and some questions. It runs awesome when warm, but having cold idle issues.
          (SOLD) 1988 327i Build Thread: http://www.r3vlimited.com/board/showthread.php?t=155086
          1970 Gruppe 2 2902 M20 Turbo Build: http://www.r3vlimited.com/board/showthread.php?t=373891

          Comment

          Working...
          X