Announcement

Collapse
No announcement yet.

E30 runs RICH AS HELL

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #61
    Originally posted by Sagaris View Post
    I'm glad the fuel economy is improving, how is the overall response and performance? Nice and crisp? I generally dont care so much about my fuel economy as long as my engine is pulling strong and the response is sharp.
    Overall response and performance has been awesome. Definatley as smooth as an M20 could be. The ECU really adjusted well since I reset it a few days ago, and idling has improved dramatically. I had the music playing and I thought my engine turned off, there was zero vibration in the cabin. Response is pretty good, virtually no lag when I go WOT.
    Honestly it's improved a lot. I still have check engine, pulling a 1211 code (DME), but I still get CEL when I change ECU's so I don't know. I might actually be able to pass inspection tomorrow so I'll see how that goes.
    Originally posted by TSI
    ♫ Rust flecks are falling on my head...♫
    OEM+

    Comment


      #62
      Just roll up to the testing station with a bottle of this hanging out of the gas filler


      and some $5 bills placed evenly across the entire span of the dashboard.

      Should be good after that.

      Comment


        #63
        After an extremely frustrating adventure on finding someone who actually knows how to drive manual in the inspection facility, I got the results.

        Considering last time I passed high idle running almost solely on denatured alcohol, and failed idle with a 3000hc PPM, I did much better.
        I got 400 failure on idle, 600 failure on high idle. If I put denatured alcohol, I'm pretty sure I'm going to pass considering the only thing I did to the car was add a new O2 sensor and TPS.
        I'm sure the only reason I'm failing now is because of my cat converter.
        Originally posted by TSI
        ♫ Rust flecks are falling on my head...♫
        OEM+

        Comment


          #64
          Originally posted by lolcantturn View Post
          fuel pressure is fine....................wahhhhhhhh.


          My ignition system is pretty darn new.

          If it helps, this is my emissions test from about a month ago


          Yes...2800 hydrocarbon parts per million........................................... ....

          these numbers indicate your cat is working....

          Complete combustion should result in CO2 approaching high 14s and 02 should be zero. O2 reduction as your speed increases is a sign the cat is helping out dramatically

          I'd say you still have some type of vacuum leak post AFM. Did you replace hoses to the evap canister?

          What about possible crankcase leaks like cam seal, cam end plugs, oil housing and what not...

          If your injector o-rings have over 100k on them then its time to swap in some new ones there too.

          Just trying to help,
          Greg

          Comment


            #65
            Originally posted by GDA View Post
            these numbers indicate your cat is working....

            Complete combustion should result in CO2 approaching high 14s and 02 should be zero. O2 reduction as your speed increases is a sign the cat is helping out dramatically

            I'd say you still have some type of vacuum leak post AFM. Did you replace hoses to the evap canister?

            What about possible crankcase leaks like cam seal, cam end plugs, oil housing and what not...

            If your injector o-rings have over 100k on them then its time to swap in some new ones there too.

            Just trying to help,
            Greg
            Wow, much appreciated help! Very cool stuff to know as well.
            On my new inspection, my CO2's are High 13's and O2 is 1.1. Is this good enough, or should it still be better?

            I know I have a leak in my valve cover as my gasket is a little leaky, cam seals look alright, but a smoke test should undoubtedly point out all these flaws. Injector O-rings have been replaced as well.

            Thanks man, I appreciate it. good info indeed.
            Originally posted by TSI
            ♫ Rust flecks are falling on my head...♫
            OEM+

            Comment


              #66
              Originally posted by lolcantturn View Post
              Wow, much appreciated help! Very cool stuff to know as well.
              On my new inspection, my CO2's are High 13's and O2 is 1.1. Is this good enough, or should it still be better?

              I know I have a leak in my valve cover as my gasket is a little leaky, cam seals look alright, but a smoke test should undoubtedly point out all these flaws. Injector O-rings have been replaced as well.

              Thanks man, I appreciate it. good info indeed.
              Yup the valve cover leak is not helping your cause at all. I think you need to fix that and install new injector o-rings and if you plugs have gotten pretty sooted from all this dirty running it might be worthwhile to install a new set before hitting the smog station for the final pass.

              As you still have O2 left over (due to extreme amounts of HC) then the DME is sensing a rich condition and is leaning out the mix and the cat can only do so much given what by products is has coming into it.

              Comment


                #67
                Time to bring this back from the dead. Did you ever figure this thing out?

                Comment


                  #68
                  yes. did you?

                  Comment


                    #69
                    Bump! Also curious if you figured this out or not.
                    Newb to all the things.

                    Comment


                      #70
                      I can't help but add my 2 cents to the "Running Rich" Issue
                      If you have the 1st generation injectors ending in 715 (6 cylinder) or 740 (4 cylinder) than chances are pretty high that the injectors are leaking.
                      I cleaned and tested about 200 injectors in the last couple of weeks and the 1st gen injectors have a very high fail rate.

                      If you checked vacuum leaks, exhaust leaks, all the injection components and couldn't find the problem, it's worth getting those tested.

                      You can see a typical 1st gen injector fail here from a m20b25 - 0280 150 715



                      more info on typical issues and fixes
                      http://www.r3vlimited.com/board/show...7&postcount=61

                      And my thread on reconditioning
                      http://www.r3vlimited.com/board/show...=266477&page=5
                      Last edited by MEPEH; 11-20-2012, 11:12 AM.
                      Get your Injectors Cleaned HERE

                      Comment


                        #71
                        Bump from the graveyard as I'm having similar issues. Saw the OP last posted July 2016 so hoping he is still around!!!!

                        Comment


                          #72
                          His last activity was a month and a half ago. If you click on a user profile, it'll tell you under their name.
                          AWD > RWD

                          Comment


                            #73
                            Did you ever find a solution? i am in the same boat right now.

                            Comment


                              #74
                              Tank Return Clogged - possible solution?

                              Hey,

                              So I have confirmed that the tank is clogged at the return line.

                              Questions:
                              1) Where does the return line go within the tank? There is a passage that starts at the nipple by the rear driver wheel and goes through the tank. Does it connect to the fuel pump?
                              2) What if I capped off the return nipple and drilled a hole/welded an AN fitting next to the original return nipple so gas can recirculate into tank. Would that work?

                              Thanks,
                              John

                              Comment

                              Working...
                              X