No announcement yet.

Megasquirt PNP Parasitic Draw

  • Filter
  • Time
  • Show
Clear All
new posts

    Megasquirt PNP Parasitic Draw

    Hey guys, I'm hoping someone might be able to point me in the right direction here.

    Over the weekend I successfully got the car running and driving on a megasquirt PNP unit hooked up to my stock M20B25. Overall, things have been going pretty well using Tune Analyze Live to get my tune in the ball park and safe enough to get me commuting to work.

    Today I came out to my car with a dead battery and after poking around some fuses I've noticed I'm getting power to fuses 22 through 28 (26 is an used port) with the key out of the ignition.

    I re-plugged in the stock ECU and checked the fuses again and they no longer have power. I have a feeling the megasquirt PNP unit thinks the key is in the ignition when it is not causing a parasitic draw on the battery. When I first installed the unit I noticed that megasquirt could be accessed regardless of the key being in the ignition with my laptop, so when I would have to power cycle it for certain settings I would have to physically unplug it and plug it back in. This doesn't seem normal to me.

    Has anyone experienced this before? I've tried looking around tunerstudio for a related ignition setting, but nothing is jumping out at me.

    Thanks in advance.


    Edit: I was mistaken about the fuses, these fuses are hot at all times regardless of what ECU is plugged into the harness. The megasquirt power issue stands though.
    Last edited by zwill23; 01-08-2019, 09:23 AM. Reason: Made a mistake troubleshooting this issue, fuses are not related

    Sounds like its wired wrong.

    Have a look up for the pin outs for your particular oem ECU, there will be 12V constants power and there will be switched ignition 12v as well.

    sounds like MS is powered by the constant 12v and not the switched one.


      I second what he's saying. Did you buy the unit new from diypnp?

      1991 325iS turbo


        Damn you guys are quick, thanks for the replies.

        I'll open it up today and check the pin outs, hopefully that's all it is and can be fixed on the work bench.

        I purchased the DIY PNP unit "brand new" from a member Trickcruiser on here during an M20 turbo part out. I was told it was never used and still in the box, it looks like it came straight from DIYautotune.


          Have you followed the whole DIY Auto Tune guide for installing it? I know with my MS3X I had to adjust the factory harness so that the main relay turned on with the ignition switch instead of the ECU. I provided my ECU with switched power only.


            Originally posted by citizen_insane View Post
            Have you followed the whole DIY Auto Tune guide for installing it? I know with my MS3X I had to adjust the factory harness so that the main relay turned on with the ignition switch instead of the ECU. I provided my ECU with switched power only.
            This was the guide I followed:


            As far as physical installation, it doesn't seem like I need to modify the stock wiring harness, at least from what I read in the start up guide. I've just done a bit more research though and I'm seeing similar instructions to what you followed with your MS3x. If I'm understanding this correctly, I would need to make jumper connections from the microsquirt module pins to the mainboard referenced below?

            Now that I am looking at the motronic pin out, the jumper connections for pins 27, 36, and 37 are starting to make sense to me. The only thing that isn't matching up is the "connector board pin 3 to 'fuel pump' on the main board." I don't see a fuel pump connection.

            I attached a picture of my board internals and a Motronic 1.3 pin out below.

            From DIY Auto Tune:

            12V Switched Input / Main Relay / Fuel Pump Relay

            This is the correct method to gain control over both the Main Relay and the Fuel Pump Relay, as well as give the DIYPNP a switched 12V power source.

            (In this example we’ll be using Relay Circuit #2 for this purpose. You could use Relay Circuit #1 with minor changes, or a proto area relay circuit if you wanted.)

            * Jumper from Connector Board Pin 27 to Relay 2 Input.

            * Jumper from Relay 2 Output to Connector Board Pin 36

            * On a V1.1 board, leave out or remove the D6 diode of the #2 relay circuit you are using here. V1.5 versions do not need this diode removed.

            * Jumper from Connector Board Pin 3 to “Fuel Pump” on the Main Board.

            * Jumper from Connector Board Pin 37 to “12V” on the Main Board.


            Motronic 1.3 Pinouts:


            Just for reference, the Motronic 1.3 173 ECU being replaced:

            Edit: I reviewed the Megasquirt PNP Gen2 specific manual again and I'm not seeing any reference to jumping board connections to gain control over the main relay. This only seems to come up with the DIYPNP solutions, so I'm a bit surprised that it would be applicable to me.

            I'm still very new to standalones and megasquirt in general though, so good chance I'm missing something.

            Megasquirt PNP Gen2 Manual Used:

            Last edited by zwill23; 12-20-2018, 02:22 PM.


              Disclaimer: I'm not sure this is the only way to do it, but it's the way that worked for me. If you don't want to chop your stock harness, you may need to find another way. I didn't use a PNP unit, I built an MS3X from parts so my setup is unique to my car.

              So there's a breakout board that DIY Autotune sells that includes new relays, that's the one they're talking about. I'm almost 100% sure that the root cause for your issue is that you've wired direct power to your ECU instead of switched power.

              In the stock Motronic, the ECU gets power at all times, but doesn't really "turn on". When you turn the key, it sends a signal to the ECU which then turns on the main relay and applies full power. With MS, you don't have all that. So you need to wire your main relay signal wire to a keyed voltage tap (I took mine from the fusebox) and then run power supply after the main relay to the MS. Then the MS can ground the O2 sensor and Fuel pump relays completing the power on sequence.

              Basically all you are doing is bypassing the function of the Motronic to control the main relay and making it controlled by the key only.

              Here are some links I found useful:

              Last edited by citizen_insane; 12-25-2018, 09:32 AM.


                Hey guys,

                Thanks for pointing me in the right direction with this issue. Between help on this thread and some clarification from the guys over at DIY AutoTune I've confirmed that my Megasquirt PNP (MSPNP2_ECU-B8793, FW Rev. 3.3.1) isn't working correctly. As a couple people pointed out, I think my unit has been wired incorrectly. I'm reverting my car back to motronic and sending the unit out tomorrow for repairs.

                I'd like to think Trickcruiser wasn't aware of this issue when he sold me the Megasquirt, but it's hard not to think I've at least been hoodwinked a bit.

                Here was my troubleshooting process if anyone runs into a similar issue in the future:

                First I verified that my main ECU relay was working correctly by checking pin continuity using the relay pin out in the ETM. The idea is that the relay might be stuck in the "on" position which would create a similar issue to what I was having. I also made sure I was receiving constant power at the correct relay terminals, again based on info from the ETM.

                To check the engine harness power I back probed terminals 27 and 36 and found 0V and constant power respectively, with the key out of the ignition. These are the correct voltages, at least for a late model E30.

                The nail in the coffin was plugging a friend's Megasquirt PNP into my harness. The unit only powered on when the key was switched to auxiliary. To double check the issue with my unit I transferred it to his car and upon seating the ECU connection the unit turned on the fuel pump and could be heard priming.


                  yeah, something in the start circuit is wrong.

                  Since it's relevant and I just found it again, here's what I've used for the start circuit for many years now using a 2n2222a and a 1n4001 diode:

                  It emulates the same behavior as the original DME (I bet your PNP is supposed to do the same thing). Ignition switch power activates this circuit, which turns on the main relay, and powers the DME.
                  Build thread