Announcement

Collapse
No announcement yet.

leave power steering disconnected??

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    leave power steering disconnected??

    87 325e. my power steering pump pulley is rubbing through my lower coolant hose. i've never had this issue before. i' ve been running the same belt (7330) and this issue did not occur. do i have the wrong size belt? should i leave it disconnected?
    thank you Robby

    #2
    On my car (323i) the lower coolant hose has a little clip that holds it on the chassis rail, keeps it away from the power steering and whatever else.

    Comment


      #3
      yes i have that secured to the hose, but somehow it is still hitting the pulley
      thinking power steering delete from condor might not be a bad idea

      Comment


        #4
        nah don't delete it. E30 power steering is great i reckon.

        Check what belt you have, sounds like its too long. Have a google around to see what belt it should be. mine is a long away from the coolant hose.

        Comment


          #5
          Something is definitely wrong. Post up a picture so we can see.

          Instagram: Reichart12

          Comment


            #6
            will post one up in the morning

            Comment


              #7
              Click image for larger version  Name:	uAfzOTnZTceIjHRc1Zrd9Q.jpg Views:	0 Size:	76.5 KB ID:	9863141
              Attached Files

              Comment


              • robby41
                robby41 commented
                Editing a comment
                1st photo is where it sits, took belt off so im not burning through hoses

              #8
              Itís a little dark to see the pic but.... are you sure youíre using the correct lower radiator hose? Sometimes switching different manufactures of hoses will have the correct bends giving more clearance Sent from my iPhone using Tapatalk

              Comment


                #9
                i've had the same hose on there for about a year and half from the prev. owner and hadn't had an issue with it.
                could something gotten "tweaked" somehow

                Comment

                Working...
                X