Announcement

Collapse
No announcement yet.

PNW Chit Chat thread

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by Matt-B View Post
    I got pulled over Friday.

    For going 60 in a 70, in the middle lane, but it was a construction zone, so the speed was lowered per the signs to 60. The cop comes to window says why are you impeding traffic, i said its 60 through here, due to construction. He says "the construction is on the other side tonight.

    Lol, i said in a construction zone, its both sides of roads, between the marked and or posted areas. He says ok well uhmm "your exhibiting the characteristics of a drunk driver going slower then needed." I said its 60, I'm going 60. I said drunk drivers don't drive in straight lines, and obey the laws 100% while driving. He asked for my ID, i said i have done nothing wrong, and unless you suspect i have committed some other crime, you may not see it. I said am i free to go, he said "yea you can go ahead and leave."


    Good on you for knowing your rights and defending them! And respecting the construction workers endanger their lives for the good of our cars..

    Since you coherently argued your point and asserted your freedom I guess that was enough to convince the officer you could drive.. If you pissed him off though he definitely could have hassled you more, personally I'll always comply and be apologetic/a bit outgoing. When I imported my E30 from Canada I joked around with the guy and he waved almost all the fees, plus noted and ignored an out headlight even though it was late at night ;D

    Do you guys think our E30s, especially those that are a bit louder or lower than stock, get extra attention from law enforcement?

    Comment


      Originally posted by Metallated View Post
      Do you guys think our E30s, especially those that are a bit louder or lower than stock, get extra attention from law enforcement?
      Absolutely yes
      Hank Ahrens
      1984 Alpine Coupe
      1978 911sc

      Comment


        Originally posted by Matt-B View Post
        I got pulled over Friday.

        For going 60 in a 70, in the middle lane, but it was a construction zone, so the speed was lowered per the signs to 60. The cop comes to window says why are you impeding traffic, i said its 60 through here, due to construction. He says "the construction is on the other side tonight.

        Lol, i said in a construction zone, its both sides of roads, between the marked and or posted areas. He says ok well uhmm "your exhibiting the characteristics of a drunk driver going slower then needed." I said its 60, I'm going 60. I said drunk drivers don't drive in straight lines, and obey the laws 100% while driving. He asked for my ID, i said i have done nothing wrong, and unless you suspect i have committed some other crime, you may not see it. I said am i free to go, he said "yea you can go ahead and leave."

        Meanwhile i saw many people going 80-90 in the 60 zone...



        RCW 46.61.021 Duty to obey law enforcement officer--Authority of officer.

        (3) Any person requested to identify himself or herself to a law enforcement officer pursuant to an investigation of a traffic infraction has a duty to identify himself or herself, give his or her current address, and sign an acknowledgment of receipt of the notice of infraction. . .


        No infraction, no ID
        This happen in Oregon or Washington?

        ... God, I could rant all day and night about tards impeding traffic and playing games with their 2ton weapons. Where is this cop when you want him?

        Comment


          It was in Wash.

          in my 98 m3


          I mean yea he can hassle me more, but I have no time for BS when i did nothing wrong and was pulled over "just because"
          I have nothing but respect for police, but its more to let them know, not everyone is gonna fold over for them.

          Our rights are there for a reason, and we need to exercise them, so they are not forgotton



          give me liberty or give me death
          lol


          Please leave feedback below, thanks

          http://www.r3vlimited.com/board/showthread.php?t=358170

          Comment


            Originally posted by 4tDX View Post
            ... God, I could rant all day and night about tards impeding traffic and playing games with their 2ton weapons.

            No. kidding.

            It's a frickin' jungle out there now, people are just getting angry about everything. If you pass someone, they take it personal now, and feel it their need to "teach you a lesson." Too many people think they are citizen cops - and know the laws.

            Though, I do have to admit, if I see anything but a PNW license plate, the red mist starts to descend.. Bonus points are accrued if it's from Texas.
            1991 325i MT2 Touring (JDM bro)
            2016 Ford Flex
            2011 Audi A3 - wife's other German car

            Comment


              I snapped my front subframe where the sway bar connects to the brackets. My front end is chattering waaaaaay took much now. Do y'all know where I can get another subframe locally? I am in Tacoma and have an 88 325e super eta. Thanks.
              Ps since I'm down in the front end, what the best way to go on bushing replacement?... I've read a lot of recent posts on polys and what not. I'm a noob and thought it would be a nice project for me and my teenage son. Cheers

              Comment


                Originally posted by mentalvacation View Post
                I snapped my front subframe where the sway bar connects to the brackets. My front end is chattering waaaaaay took much now. Do y'all know where I can get another subframe locally? I am in Tacoma and have an 88 325e super eta. Thanks.
                Ps since I'm down in the front end, what the best way to go on bushing replacement?... I've read a lot of recent posts on polys and what not. I'm a noob and thought it would be a nice project for me and my teenage son. Cheers
                If someone local doesn't speak up, I have one for $60.

                If I were you, I would replace the tie rod assemblies, the control arms and bushings, sway bar links and bushings, all with OE parts and stock rubber bushings (particularly so, if the car is not a track car and will only see street time).
                '72 2002 pickup | '88 M5 | '89 330is | '89 M3 | '01 Z3M | '11 328xi-t

                Comment


                  I have a subframe in Bremerton for $60. Come get 'er :) Ill pm you now

                  As far as the front bushings... I cant recommend my m3 offset red 75d AKG poly ones enough. They have only squeaked on me a few times, were cheap, easy to install, and very high quality.

                  The feeling of solid bushings for the FCAB (front control arm bushings) is the only way in my opinion... worn out stockers you can feel flex under intense cornering and it sucks

                  Comment


                    Hey guys just came to ask for some advice. So i fixed the whole front end on my e30 after my crash and it ran when i parked it but now 6months later it will not start. Any trouble shooting methods that i should look into? Im a lot better at cosmetics than engine stuff im a noob. If it starts it only runs for 3 seconds thrn bogs out.
                    https://youtu.be/kNiQP6BAc6w

                    Sent from my SM-G920V using Tapatalk

                    Comment


                      Originally posted by DaWildBeast View Post
                      Hey guys just came to ask for some advice. So i fixed the whole front end on my e30 after my crash and it ran when i parked it but now 6months later it will not start. Any trouble shooting methods that i should look into? Im a lot better at cosmetics than engine stuff im a noob. If it starts it only runs for 3 seconds thrn bogs out.
                      https://youtu.be/kNiQP6BAc6w

                      Sent from my SM-G920V using Tapatalk


                      Looks like it's not completely together, could be something simple like a vacuum leak.


                      Sent from my iPhone using Tapatalk Pro

                      Comment


                        Originally posted by Pdxseth View Post
                        Looks like it's not completely together, could be something simple like a vacuum leak.


                        Sent from my iPhone using Tapatalk Pro
                        Well yes, its not completely together because the radiator, lights, grill, and hood are not on. Ive already had to take out the radiator a few times so im going to wait for it to start before i throw it back in...

                        Sent from my SM-G920V using Tapatalk

                        Comment


                          Is the Crank position sensor still good? Is it still connected and mounted firmly? Are you getting spark at the plug? Is there fuel at the fuel rail? Are you smelling unburnt fuel at the tailpipe after cranking it?

                          It doesn't take much to get one of these to run (even if runs like crap) so you should start with some of those basics.

                          Fuel, spark, timing and compression.
                          1991 325i MT2 Touring (JDM bro)
                          2016 Ford Flex
                          2011 Audi A3 - wife's other German car

                          Comment


                            Doesn't take much to damage an M20 CPS, especially if the car was in a front end collision. I would just replace it for good measure.
                            '72 2002 pickup | '88 M5 | '89 330is | '89 M3 | '01 Z3M | '11 328xi-t

                            Comment


                              Originally posted by Austin! View Post
                              Doesn't take much to damage an M20 CPS, especially if the car was in a front end collision. I would just replace it for good measure.
                              Is it worth going oem for the $100+ price tag or is bosch good?

                              Sent from my SM-G920V using Tapatalk

                              Comment


                                Originally posted by djjerme View Post
                                Is the Crank position sensor still good? Is it still connected and mounted firmly? Are you getting spark at the plug? Is there fuel at the fuel rail? Are you smelling unburnt fuel at the tailpipe after cranking it?

                                It doesn't take much to get one of these to run (even if runs like crap) so you should start with some of those basics.

                                Fuel, spark, timing and compression.
                                I will check all of this tonight. I honestly just didnt know where to start.

                                Sent from my SM-G920V using Tapatalk

                                Comment

                                Working...
                                X