Announcement

Collapse
No announcement yet.

M20 ETA, no power, super rich, very rough idle

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    M20 ETA, no power, super rich, very rough idle

    my 86 325 was running beautifully, but now it is giving me trouble.. looking for suggestions. I haven't started diagnosis yet, but here's the situation

    starts, but sputtering hard, like it's missing
    when it's like this the engine does not respond to throttle at all
    exhaust is super rich and smokey, so AFRs aren't right
    problem gets worse after it's rained

    car is basically undrivable right now, even up and down the driveway. Gonna pull the plug wires and AFM. maybe the TPS? coil?

    all suggestions welcome - would like to get this bad boy running smoothly again today.
    I BUY/SELL REFURBISHED CM5907s & CM5908s

    HOWTOs:
    DB vert plastic bumpers
    OEM Keys
    MTech1 docs

    88 ix Lach/Card
    91 ic Calypso 3.1
    86 Cosmo 2.7

    OEM+ or bust!


    reelizmpro: I will always be an e30 guy.. I still do all of my own labor
    TrentW: There's just something so right about a well-built M20 in an E30
    e30m3s54turbo: I save my money for tuner parts.

    #2
    ETAs are so weird.. pulled the plug on a valve on top of the valve cover and idle smoothed out quite a bit. still rough and running rich though.

    Plug wires are brand new Bremi. pulling each plug worsened the idle. probably nothing wrong on the ignition side.

    Also inspected the CPS wire and it's got a hacked up solder job with electrical tape on it right near the thermostat housing. will post pics and vids in a bit.
    I BUY/SELL REFURBISHED CM5907s & CM5908s

    HOWTOs:
    DB vert plastic bumpers
    OEM Keys
    MTech1 docs

    88 ix Lach/Card
    91 ic Calypso 3.1
    86 Cosmo 2.7

    OEM+ or bust!


    reelizmpro: I will always be an e30 guy.. I still do all of my own labor
    TrentW: There's just something so right about a well-built M20 in an E30
    e30m3s54turbo: I save my money for tuner parts.

    Comment


      #3
      Have you tried disconnecting the cold start valve
      Deck Lid and soft top Shocks on hand

      Seat shocks on hand for immediate shipment
      https://www.r3vlimited.com/board/sho...86#post4944786
      Alice the Time Capsule
      http://www.r3vlimited.com/board/showthread.php?t=360504
      87 Zinno Cabrio barn find 98k and still smells like a barn. Build thread http://www.r3vlimited.com/board/show...20#post3455220

      Comment


        #4
        yes...that's the valve I referred to in my 2nd post. idled faster and smoother, then turned rough again
        I BUY/SELL REFURBISHED CM5907s & CM5908s

        HOWTOs:
        DB vert plastic bumpers
        OEM Keys
        MTech1 docs

        88 ix Lach/Card
        91 ic Calypso 3.1
        86 Cosmo 2.7

        OEM+ or bust!


        reelizmpro: I will always be an e30 guy.. I still do all of my own labor
        TrentW: There's just something so right about a well-built M20 in an E30
        e30m3s54turbo: I save my money for tuner parts.

        Comment


          #5
          so there's no CPS on an ETA like a 325i. There's a TDC sensor mounted near the timing mark, but I'm not sure it works the same way. All I know:

          -- spark plug wires look new
          -- when I disconnect the valve on top of the motor (cold start valve?) the idle smooths out a bit, increases to 1500 or so
          -- AFM looks fine mechanically, flap moves ok, air filter is clean
          -- the engine produces little power, barely revs and backfires like its timing is off

          car is obviously undrivable at the moment. I can wait to do a 325i conversion, but I'd really like to get this fixed now.
          I BUY/SELL REFURBISHED CM5907s & CM5908s

          HOWTOs:
          DB vert plastic bumpers
          OEM Keys
          MTech1 docs

          88 ix Lach/Card
          91 ic Calypso 3.1
          86 Cosmo 2.7

          OEM+ or bust!


          reelizmpro: I will always be an e30 guy.. I still do all of my own labor
          TrentW: There's just something so right about a well-built M20 in an E30
          e30m3s54turbo: I save my money for tuner parts.

          Comment


            #6
            Does it have a vacuum advance distributor?

            Comment


              #7
              Originally posted by bradnic View Post
              so there's no CPS on an ETA like a 325i. There's a TDC sensor mounted near the timing mark, but I'm not sure it works the same way. All I know:

              -- spark plug wires look new
              -- when I disconnect the valve on top of the motor (cold start valve?) the idle smooths out a bit, increases to 1500 or so
              -- AFM looks fine mechanically, flap moves ok, air filter is clean
              -- the engine produces little power, barely revs and backfires like its timing is off

              car is obviously undrivable at the moment. I can wait to do a 325i conversion, but I'd really like to get this fixed now.
              There are 2 references sensors I the bell housing that are identical and one does the job of a CPS. They are known to be problematic especially where they connect on the side of the block next to the starter. The plastic connectors there tend to disintegrate.
              Deck Lid and soft top Shocks on hand

              Seat shocks on hand for immediate shipment
              https://www.r3vlimited.com/board/sho...86#post4944786
              Alice the Time Capsule
              http://www.r3vlimited.com/board/showthread.php?t=360504
              87 Zinno Cabrio barn find 98k and still smells like a barn. Build thread http://www.r3vlimited.com/board/show...20#post3455220

              Comment


                #8
                Check for moisture or corrosion inside the distributor cap.
                Lorin


                Originally posted by slammin.e28
                The M30 is God's engine.

                Comment


                  #9
                  Thanks for the suggestions. Gonna try again this weekend, starting with the cold start valve. @jeffnhiscars was kind enough to send out some spares. @LJ851 / Lorin I have a replacement distributor cap and rotor. Will head down that path once I’ve ruled out cold start valve problems
                  I BUY/SELL REFURBISHED CM5907s & CM5908s

                  HOWTOs:
                  DB vert plastic bumpers
                  OEM Keys
                  MTech1 docs

                  88 ix Lach/Card
                  91 ic Calypso 3.1
                  86 Cosmo 2.7

                  OEM+ or bust!


                  reelizmpro: I will always be an e30 guy.. I still do all of my own labor
                  TrentW: There's just something so right about a well-built M20 in an E30
                  e30m3s54turbo: I save my money for tuner parts.

                  Comment


                    #10
                    Hey I once accidentally swapped the cold start (“7th injector”) with one of the other plugs near the thermostat housing when I was putting it back together after replacing the head gasket. It ran but was super rich, then died on me. Hope that’s not your problem...

                    Comment

                    Working...
                    X