Announcement

Collapse
No announcement yet.

Big Al's Revenge: an OEM+, MTech1 325e restoration

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts



    Staszek, I ended up just ordering directly from their site: https://www.lamin-x.com/precut-film-...sid=MWts7buayQ

    I plugged in my model/year but you can adjust at the top, they should all be the same for the euros. Also, make sure you order the euro spec covers (obvi) as the US spec covers are a little different. They also sell various sized plain sheets of material, I ended up buying an 8x8in piece to cut for the fogs when I eventually get around to putting those on.
    Albie

    '86 325e Zinnoberrot /// '02 325ci Schwarz II /// '18 M4 Azurite Black Metallic ///

    Albie325 Build Thread | Albie325 Feedback | Albie's M4 European Delivery

    Comment


      Originally posted by Albie325 View Post


      Staszek, I ended up just ordering directly from their site: https://www.lamin-x.com/precut-film-...sid=MWts7buayQ

      I plugged in my model/year but you can adjust at the top, they should all be the same for the euros. Also, make sure you order the euro spec covers (obvi) as the US spec covers are a little different. They also sell various sized plain sheets of material, I ended up buying an 8x8in piece to cut for the fogs when I eventually get around to putting those on.
      Good idea because I have new glass on the fogs too! Thanks!
      Euro Delivery Thread///E30 Project Klaus

      Comment


        I'll be in TN @ The Tail of the Dragon in mid-May and last week of July.

        I'll leave you a note at the overlook.
        I do things.

        Comment


          It's taken a few weeks to get the paint selection process sorted. After deciding on single stage I went to my paint shop only to find out that they didn't carry any single stage aside from some super cheap stuff in paint code 138 (zinnoberrot). They pointed me in the direction of a few other local shops and they also didn't have any single stage in 138.

          Back to the drawing board. I started pricing out various brands and materials for a base/clear system and after a ton of discussion with a bunch of people, I've decided to use Axalta Cromax products for this car. When the F82 booboo was repainted they actually used Cromax as the shop said the paint match is excellent particularly with BMW's. I've also reached out to a guy on YouTube that I've been watching who has (conveniently for my learning and planning purposes) repainted an MTech1 kit, MTech2 kit, E34 M5, and E30 M3 all using Cromax products with excellent results. I plan to place my order by Wed/Thursday of this week so I can start breaking down the car.

          I haven't been asleep at the wheel, however. I've gotten the MTech kit pretty much ready for primer:





          The front air dam came with one set of the front vents still uncut. I like the look of the vents all cut out, and also the upper vents allow for better air flow for the A/C, and I've already documented how difficult it was to get that working. Lemme say I was a bit puckered while cutting these out:



          Took my time and it came out great:





          The most time consuming part of prepping the MTech 1 kit was sanding out all the areas with the 3 grooves by hand. It easily took me as long just to do those spots as the rest of the entire piece in most cases. Most pieces (front, rear, and one sideskirt) had only 1-2 layers of paint, however one sideskirt was painted easily 6-7 times and took the longest to sand down. There's a few small spots that will need repair (I'll use 3M 05887 plastic repair) and some small rock chip filler here and there but otherwise ready for primer.

          I was also able to order a few parts that I thought were NLA, but found through Schmeidmann for much cheaper than anticipated:






          I'll hopefully get the ball rolling on the car itself this weekend.

          Also, now that I've decided on which bits I will actually be using from the MTech kits I have, I will be listing the duplicate parts (front and rear air dams, sideskirts, and some various extra trim bits I have) for sale over the next couple of days. I need the space in the garage for all the trim etc that will be coming off of the car, as well as the cash to help pay for the paint and other supplies. If you know anyone looking for an OEM MTech 1 kit in excellent shape, send them my way.



          Albie

          '86 325e Zinnoberrot /// '02 325ci Schwarz II /// '18 M4 Azurite Black Metallic ///

          Albie325 Build Thread | Albie325 Feedback | Albie's M4 European Delivery

          Comment


            Exciting times! Glad to see updates!

            Comment


              Ended up driving up to see my parents last weekend and took the E30 since it will be one of the last times for awhile that I'll be able to drive it. It was also the first time Big Al got to drive the car since swapping in the 5 speed, I think he enjoyed it:



              Anyway, a quick question for you guys:

              Over the last 2 weeks or so I've noticed my inspection light keeps coming on. I'll reset it and get all greens across the board and it'll stay that way for a day or so, but the next day I'll go out to start the car and the inspection light will be back on. I just had the cluster refurbed by BavRest within the last 6 months, is it possible the SI batteries are already no good?? Car starts and runs fine otherwise.
              Albie

              '86 325e Zinnoberrot /// '02 325ci Schwarz II /// '18 M4 Azurite Black Metallic ///

              Albie325 Build Thread | Albie325 Feedback | Albie's M4 European Delivery

              Comment


                Seems like an SI battery problem. Ask Greg about it, he'll help you out.

                Comment


                  speaking of that, my SI battery isn't working either, I have to look at my receipt to see if I had BavRest replace it.
                  Paynemw
                  1986 Toyota 4Runner SR5 - Sold!
                  the ebb and flow of 325is ownership - In RVA
                  1988 BMW 535is - RIP but my dream BMW

                  Comment


                    Digitalwave yah I'll have to reach out, just wanted to avoid removing the cluster again and taking it apart. I'd like to avoid shipping the whole thing out to him again.
                    Albie

                    '86 325e Zinnoberrot /// '02 325ci Schwarz II /// '18 M4 Azurite Black Metallic ///

                    Albie325 Build Thread | Albie325 Feedback | Albie's M4 European Delivery

                    Comment


                      I just a thought regarding you SI Board issues. Did you use the wrong set of screws to hold the bezel back in place? If you use the longer screws, they go too far and damage the SI board. People often mix up the longer and shorter sets of screws when reinstalling the cluster.

                      Comment


                        Yeah, I feel you about having to ship it off again. I need to have something done about my Tach needle, it is loose and wanders around. My tach readings are all over the place.
                        I do things.

                        Comment


                          the story about your neighbor is awesome! Something about the F80 just looks so good. My neighbors are gear heads, but Subaru fans. Him and his wife both have Subarus. One has an FRS and the other has a Legacy? Great work on this!

                          Comment


                            Originally posted by mike.bmw
                            I just a thought regarding you SI Board issues. Did you use the wrong set of screws to hold the bezel back in place? If you use the longer screws, they go too far and damage the SI board. People often mix up the longer and shorter sets of screws when reinstalling the cluster.
                            Yah I've read enough horror stories to make sure the screws are correct, but good thought. If it were that and the thing was damaged you'd think it wouldn't have worked form the get-go, however had been working fine for a few months up until recently. Maybe was damaged by a prior owner (it was a spare I had), I'll have to pull it out and check but don't remember seeing any damage on it when I took it apart.

                            Melon, hoping he'll let me send out just the SI board, will update.

                            jeenyus too bad about the Sub's, although a gear head is still a gear head. My fianceƩ and I always argue about who the worst drivers on the road are between Subaru's and Prius drivers (my vote is for the Prius all day long). Although I guess Subaru WRX/FRS drivers are cut from a different cloth than kale chip-eating, birkenstock-wearing Forester drivers.
                            Albie

                            '86 325e Zinnoberrot /// '02 325ci Schwarz II /// '18 M4 Azurite Black Metallic ///

                            Albie325 Build Thread | Albie325 Feedback | Albie's M4 European Delivery

                            Comment


                              Don't forget if you remove the cluster and drive the car, the alternator isn't going to work so it will drain your battery quickly.

                              Comment


                                Digitalwave, damn, never knew that. If I have to send it out I have a few spare clusters I can use in the meantime.
                                Albie

                                '86 325e Zinnoberrot /// '02 325ci Schwarz II /// '18 M4 Azurite Black Metallic ///

                                Albie325 Build Thread | Albie325 Feedback | Albie's M4 European Delivery

                                Comment

                                Working...
                                X