Announcement

Collapse
No announcement yet.

The Detailed E30 R-134a Conversion Thread/DIY

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    I can not seem to find R134a cans here in Germany. Either 1kg, 2kg or 12kg tanks which can not be shipped or an extra charge for shipping since they are considered "dangerous goods".

    I just received new parallel flow condenser, the correct dryer/receiver, pressure switch and expansion valve, along with various O-rings.

    The R134a freon, compressor oil and vacuum pump is all i need. But now i need to ask, if it is alright to use 12a gas (which replaced R134a/R12) or a similar "replacement for R134a". Or do all the hardware myself, top up oil and let a professional vacuum test the system and charge for me.

    What do you guys recommend? is that replacement R134a gas alright and go ahead? or let a professional shop do the filling/vacuum part?

    Comment


      Originally posted by 325e '87 View Post
      Ok, I replace the condenser and the dryer, resealed and held 30 vacuum for about 12 hours.

      I cant get my system to draw in more than about. 10oz. Of refrigerant. Im getting kind of angry and considering pumping it back down to vacuum and trying again.

      My pressures are nearly factory, 40psi low, hovering around 200psi high. I know the pressures need to go up from where they are but Ive been running my engine for an hour now, revving sometimes. When I rev it my low side drops to around 20psi, high side drops a little.

      I'm struggling with the same exactl problem...it's killing me.

      Comment


        Originally posted by Garemie View Post
        I'm struggling with the same exactl problem...it's killing me.
        It took about 8 hours of charging time yesterday to get 24oz of Freon into my system. I need to get at least 4 more in today.

        After some fiddling around I discovered that the can tap i ordered is probably the problem. The flow restriction it makes is ridiculous. After i tap a can and open the tap valve there is inconsistent flow and I found one position for the valve that allows the Freon to exit, its about 1/2 open. Test your tap and see if its your problem too.
        My son has the 1987 325e, 2 door, 5speed
        I daily the 1989 325i, 4 door, 5speed

        Comment


          Originally posted by 325e '87 View Post
          It took about 8 hours of charging time yesterday to get 24oz of Freon into my system. I need to get at least 4 more in today.

          After some fiddling around I discovered that the can tap i ordered is probably the problem. The flow restriction it makes is ridiculous. After i tap a can and open the tap valve there is inconsistent flow and I found one position for the valve that allows the Freon to exit, its about 1/2 open. Test your tap and see if its your problem too.
          I'm not using a side puncture can tap, I'm using a thread on type. Flows like a mad man. Today I took it all apart again (kill me) and looked for blockages and anything weird. Blew out the evap core a little. I cleaned the screen on the compressor. It's been on vacuum for an hour now. Going to try again. Probably won't get any different results but who knows.

          Going by the sight glass, it appears full at like 12oz. Anything more and it looks overfilled.

          Comment


            Much of the physical restriction when pulling a vac and filling is from the schraeder valve. It can be removed and replaced with a core removal tool. The second most common problem is latent moisture in the system which can actually settle in to the compressor oil and become quite stubborn to remove. The only way to effectively deal with it is to have a micron gauge.

            Then there's not purging your hoses properly, inadvertently letting air back in and not having the right amount of oil.
            Deck Lid and soft top Shocks on hand

            Seat shocks on hand for immediate shipment
            https://www.r3vlimited.com/board/sho...86#post4944786
            Alice the Time Capsule
            http://www.r3vlimited.com/board/showthread.php?t=360504
            87 Zinno Cabrio barn find 98k and still smells like a barn. Build thread http://www.r3vlimited.com/board/show...20#post3455220

            Comment


              I think ultimately I didn't properly flush the system. It's a heat wave in my area, I think I'm going to hand this over to a shop to have it flushed and refilled. I'm going to save myself from heat stroke while working on it.


              It's gotta just be too much oil. Probably mineral oil too.

              Comment


                Originally posted by Garemie View Post
                I think ultimately I didn't properly flush the system. It's a heat wave in my area, I think I'm going to hand this over to a shop to have it flushed and refilled. I'm going to save myself from heat stroke while working on it.


                It's gotta just be too much oil. Probably mineral oil too.
                Mineral oil has to be thoroughly flushed before converting as it does not get along with r134 at all. I'm not exactly sure what the results are but I do know they are bad.
                Deck Lid and soft top Shocks on hand

                Seat shocks on hand for immediate shipment
                https://www.r3vlimited.com/board/sho...86#post4944786
                Alice the Time Capsule
                http://www.r3vlimited.com/board/showthread.php?t=360504
                87 Zinno Cabrio barn find 98k and still smells like a barn. Build thread http://www.r3vlimited.com/board/show...20#post3455220

                Comment


                  What did you guys do regarding the high pressure side valve?

                  Managed to remove the schrader valve from the low pressure side, and screw in the R134a adaptor, hood closes without issues.

                  The high pressure side adaptor sticks out about 1" or so, before the hood support hinge hits it. Can that whole hose be "twisted" somehow (when removing for replacing the o-rings), or keep the R12 factory fitting and screw in the R134a when filling only?

                  BMW does not make that hose anymore, it is from the evap to receiver/dryer line.

                  Comment


                    There are different configurations of adaptors so just find one that fits. It can be tight but I've never heard of anyone have to mod that pipe to get one on.
                    Deck Lid and soft top Shocks on hand

                    Seat shocks on hand for immediate shipment
                    https://www.r3vlimited.com/board/sho...86#post4944786
                    Alice the Time Capsule
                    http://www.r3vlimited.com/board/showthread.php?t=360504
                    87 Zinno Cabrio barn find 98k and still smells like a barn. Build thread http://www.r3vlimited.com/board/show...20#post3455220

                    Comment


                      Originally posted by jeffnhiscars View Post
                      There are different configurations of adaptors so just find one that fits. It can be tight but I've never heard of anyone have to mod that pipe to get one on.
                      Thank you, i shall continue searching to find a "shorter" high pressure side adapter then.

                      Comment


                        Originally posted by S.J.1981 View Post
                        Thank you, i shall continue searching to find a "shorter" high pressure side adapter then.
                        Please reply back if you find one. I'm looking for one too
                        New Seat Shocks for Sale

                        Comment


                          Originally posted by rzmoser View Post
                          Please reply back if you find one. I'm looking for one too
                          Will do.

                          Comment


                            I found the following adapters, i need to measure the length of the ones i have.

                            I am fairly certain, i found some that were 33 mm in height/length (not including the cap).

                            For my 1990 325i both fittings need to be 7/16", but again i shall double check later today.
                            Attached Files

                            Comment


                              Originally posted by 325e '87 View Post
                              Ok, I replace the condenser and the dryer, resealed and held 30 vacuum for about 12 hours.

                              I cant get my system to draw in more than about. 10oz. Of refrigerant. Im getting kind of angry and considering pumping it back down to vacuum and trying again.

                              My pressures are nearly factory, 40psi low, hovering around 200psi high. I know the pressures need to go up from where they are but Ive been running my engine for an hour now, revving sometimes. When I rev it my low side drops to around 20psi, high side drops a little.

                              What's the temp coming out the vents?
                              1992 325i 'vert
                              1988 320i Touring
                              1977 530i
                              2015 328i - Euro Delivery/Performance Center Delivery
                              2001 325i - R.I.P.
                              BMWCCA
                              E30CCA

                              Comment


                                Holding a vacuum doesn't mean there's no air or residual moisture in the system. Not being able to give it a full charge typically means there's something in there that shouldn't be. It's so easy to let some air back in after pulling a vac
                                Deck Lid and soft top Shocks on hand

                                Seat shocks on hand for immediate shipment
                                https://www.r3vlimited.com/board/sho...86#post4944786
                                Alice the Time Capsule
                                http://www.r3vlimited.com/board/showthread.php?t=360504
                                87 Zinno Cabrio barn find 98k and still smells like a barn. Build thread http://www.r3vlimited.com/board/show...20#post3455220

                                Comment

                                Working...
                                X