Announcement

Collapse
No announcement yet.

(Yet another) M42 top end refresh and engine reseal (mid-2021)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    oh, my daughter and I did drive it more today around the neighborhood. We haven't yet romped on it but we will. I noticed some power steering fluid leak on the hose from the reservoir to the rack.

    The one hose I didn't replace because it looked good and is $100+. It still may be just oil burning off so I'll keep an eye on it.

    ~Jason
    Last edited by jsnppp; 01-17-2022, 07:10 PM.

    1991 BMW 318is - AlpineWeiss II
    1991 BMW 318is - DiamondSchwartz
    1988 Acura Integra - Blue
    1973 BMW 2002 Tii - Baikal
    2002 Toyota 4Runner SR5 sport - Black

    Comment


      Well, if it is starting repeatedly and reliably then I'd say that it's a good indication that you did all of the important stuff properly! The PS hoses are sort of a PITA...the ones from the reservoir do seem to leak chronically. I assume that the rubber dries & cracks a little up at the reservoir nipples. Since those are all zero-pressure lines, it is probably fine to find some generic PS hose of the same ID, some metal union barbs, and to chop off the cracked ends and splice on new ones. That is what appears to be the case with my hoses anyway!

      My cluster also has the last LED not lighting up, and even after getting a fully refurbed one. I am not sure if it ever lit up, although I would assume that it is supposed to. Let me know if you figure that one out.

      Transaction Feedback: LINK

      Comment


        Originally posted by jsnppp View Post
        oh, my daughter and I did drive it more today around the neighborhood. We haven't yet romped on it but we will. I noticed some power steering fluid leak on the hose from the reservoir to the rack.

        The one hose I didn't replace because it looked good and is $100+. It still may be just oil burning off so I'll keep an eye on it.

        ~Jason
        Congrats!! It's got to be a good feeling to drive it around a bit. A proper project always has some sort of minor issue that needs addressed after....I'd be nervous if there wasn't.

        Comment


          Originally posted by mjweimer View Post

          Congrats!! It's got to be a good feeling to drive it around a bit. A proper project always has some sort of minor issue that needs addressed after....I'd be nervous if there wasn't.
          Totally agree with you. This one has been pretty minor so far. It appears to be eager to go and no major sounds/leaks to take care of. Just working through the cluster (believe I found the issue), reinstalling sunroof and looking into why the brake lining light decided to turn back on. :-)

          1991 BMW 318is - AlpineWeiss II
          1991 BMW 318is - DiamondSchwartz
          1988 Acura Integra - Blue
          1973 BMW 2002 Tii - Baikal
          2002 Toyota 4Runner SR5 sport - Black

          Comment


            Slight knock when you start it up. Light. Seems to go away after 30sec or so. It's relatively cold out here so maybe it is hydraulics.

            I read through a bunch of posts on this topic, mostly it's alarming if it doesn't go away. Note we still haven't really driven it.

            I'll capture it on video..

            1991 BMW 318is - AlpineWeiss II
            1991 BMW 318is - DiamondSchwartz
            1988 Acura Integra - Blue
            1973 BMW 2002 Tii - Baikal
            2002 Toyota 4Runner SR5 sport - Black

            Comment


              It actually goes away in seconds, I'm thinking it's just hydraulic lifters...

              Spent a few hours today tracing back brake lining light + soldering in the oil inspection bulb (converted to LED). I reflowed all the cluster contacts but it wound up being a flaky connection at the right rear wheel. Wire looked fine on the outside but apparently had a break. Soldering under the car is always fun. :-)

              I now have a "pegged temp gauge" issue. Must have been when I reflowed it because it was fine before. Pulled the cluster again and shouldn't be hard to trace.
              Last edited by jsnppp; 01-23-2022, 06:38 PM.

              1991 BMW 318is - AlpineWeiss II
              1991 BMW 318is - DiamondSchwartz
              1988 Acura Integra - Blue
              1973 BMW 2002 Tii - Baikal
              2002 Toyota 4Runner SR5 sport - Black

              Comment


                That'll be lifters. What oil are you running? Might be better with a 0w or 10w, if you've got thicker
                sigpic

                (clicky on piccy to get to thread)

                Comment


                  Originally posted by econti View Post
                  That'll be lifters. What oil are you running? Might be better with a 0w or 10w, if you've got thicker
                  I put in what I had for dino oil on this first refill. It's thicker than recommended for sure, and it's been a bit colder here. When I change it for the first time (after 100 miles or so) I'll put in 0w or 10x40 (whatever dino oil is recommended). Hesitant to go with full synth in case it leaks!

                  Jason

                  1991 BMW 318is - AlpineWeiss II
                  1991 BMW 318is - DiamondSchwartz
                  1988 Acura Integra - Blue
                  1973 BMW 2002 Tii - Baikal
                  2002 Toyota 4Runner SR5 sport - Black

                  Comment


                    We are still ironing out some details. I haven't been maintaining it on a charger and last time we drove it around the neighborhood it died and then wouldn't turn over with the key. Battery was nearly empty! Started it in reverse with a clutch pop (daughter was impressed) and got it home. At the end the tach and speedometer weren't even working! The charger said it had 10v once I plugged it in. Damn.

                    I haven't noticed that the battery light was not on when I first turned the key. So, clearly it's not been charging. It does need a new battery.

                    Ran through the usual suspects. Checked B+ for 12 volts (all the time) and D+ for 12volts when key is at position 2. Then pulled the cluster (again) to verify bulb wasn't burnt. Was fine.

                    So, next step was to pull the voltage regulator. There is a cheap Hella that appears to have some wear. It's an 80amp alternator and doesn't have loose bearings or other noise, so I'm hopeful that it's just voltage regulator. Any other thoughts are welcome. New one ordered.





                    While alternator out, took the opportunity to change transmission fluid. Used Valvoline ATF but will switch to Redline D4AF when we pull the transmission to redo rear main seal and transmission seals (+ other stuff) later this Spring.

                    Sharf - not bad. Old oil was relatively clear. When we change it later this year can see what it looks like again.





                    Cleaned off before replacing:



                    Filled up. Ran an extension hose up through the engine bay.



                    More soon! Once the alternator/charging is fixed we can take it out farther and get it inspected.
                    Last edited by jsnppp; 02-08-2022, 07:44 PM.

                    1991 BMW 318is - AlpineWeiss II
                    1991 BMW 318is - DiamondSchwartz
                    1988 Acura Integra - Blue
                    1973 BMW 2002 Tii - Baikal
                    2002 Toyota 4Runner SR5 sport - Black

                    Comment


                      What is the battery reading with the car on at idle?
                      Alex 88 m5 | 91 318is | 19 Subaru Ascent
                      BMW Tool Rentals & Fender Roller

                      Comment


                        Originally posted by monty23psk View Post
                        What is the battery reading with the car on at idle?
                        I believe 0 volts. I pulled the negative terminal off the battery while idling and the car immediately died. My guess is alternator isn't putting out anything at the moment.

                        At least thats the theory at the moment.

                        1991 BMW 318is - AlpineWeiss II
                        1991 BMW 318is - DiamondSchwartz
                        1988 Acura Integra - Blue
                        1973 BMW 2002 Tii - Baikal
                        2002 Toyota 4Runner SR5 sport - Black

                        Comment


                          Originally posted by jsnppp View Post

                          I believe 0 volts. I pulled the negative terminal off the battery while idling and the car immediately died. My guess is alternator isn't putting out anything at the moment.

                          At least thats the theory at the moment.
                          The car should show something, with both leads on and car is on. Knowing the voltage on the battery (car has to be on and both terminals connected), can tell you if issue is with alternator, VR, or something else.
                          Alex 88 m5 | 91 318is | 19 Subaru Ascent
                          BMW Tool Rentals & Fender Roller

                          Comment


                            Ah I misunderstood your ask. I can't check the voltage now b/c I removed the alternator. All I do know is that regardless of the battery voltage at idle, the engine would turn off immediately if I pulled the negative terminal. This tells me the alternator wasn't putting out enough to run the car.

                            I'll keep at it, once I get the new VR I can test more things assuming it doesn't fix the issue..

                            Jason

                            1991 BMW 318is - AlpineWeiss II
                            1991 BMW 318is - DiamondSchwartz
                            1988 Acura Integra - Blue
                            1973 BMW 2002 Tii - Baikal
                            2002 Toyota 4Runner SR5 sport - Black

                            Comment


                              If you pull the negative terminal connection, the car will die regardless of the state of the battery or alternator. It makes the whole electrical system go open circuit and there is no return path for the ignition, fuel injection, etc.

                              Chances are that the battery is just totally crapped out. Even with a good alternator, if the internal electrodes are totally eroded and/or the water levels are super low, it won't take a charge. Hopefully it is just a matter of replacing the battery!

                              Transaction Feedback: LINK

                              Comment


                                Originally posted by bmwman91 View Post
                                If you pull the negative terminal connection, the car will die regardless of the state of the battery or alternator. It makes the whole electrical system go open circuit and there is no return path for the ignition, fuel injection, etc.

                                Chances are that the battery is just totally crapped out. Even with a good alternator, if the internal electrodes are totally eroded and/or the water levels are super low, it won't take a charge. Hopefully it is just a matter of replacing the battery!

                                Ha, so it may not be the alternator! But since the battery is just one arm of the circuit (directly connected to D+), if the alternator was healthy wouldn't the system not even know the battery was gone?

                                Regardless, that battery is less than excellent.

                                A new VR never hurts and I can pick up a new battery by Wednesday too.

                                Thanks folks. Will update when I have more!

                                1991 BMW 318is - AlpineWeiss II
                                1991 BMW 318is - DiamondSchwartz
                                1988 Acura Integra - Blue
                                1973 BMW 2002 Tii - Baikal
                                2002 Toyota 4Runner SR5 sport - Black

                                Comment

                                Working...
                                X