Announcement

Collapse
No announcement yet.

Melon's E30 Build.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    I was just denied Hagerety?
    No ticket history
    10k value declared value , daily driven and 3,500k miles.

    Comment


      Probably since you listed it as daily driven
      1989 325i LS Swap (Money Pit):https://www.r3vlimited.com/board/sho...d.php?t=244933
      COTM Feb 2019: https://www.r3vlimited.com/board/sho...d.php?t=428404

      Comment


        I'm also 33.
        I do things.

        Comment


          Originally posted by Sonny View Post
          I was just denied Hagerety?
          No ticket history
          10k value declared value , daily driven and 3,500k miles.
          because M10 with dented fender
          Simon
          Current Cars:
          -1986 BMW 325e & 1968 Datsun Roadster 2000
          Previous Car Count : 21 ... and climbing...
          Originally posted by Melon
          Let it be known to all. Simon fucking keeps it real.

          Comment


            Originally posted by 2mAn View Post
            because M10 with dented fender
            Let it be known to all. Simon fucking keeps it real.
            I do things.

            Comment


              Originally posted by Melon View Post
              Let it be known to all. Simon fucking keeps it real.
              about to get sig'd again my friend

              edit: just to sort of stay on topic... I have hagerty on my Datsun with a $15k value, probably upping it to $20k on my next renewal. E30 is under Allstate with the wifes POSUV
              Simon
              Current Cars:
              -1986 BMW 325e & 1968 Datsun Roadster 2000
              Previous Car Count : 21 ... and climbing...
              Originally posted by Melon
              Let it be known to all. Simon fucking keeps it real.

              Comment


                Allstate is pretty good, that and State farm seem to offer the best coverage, best service and customer care.

                The Datsun is awesome man, love it.
                I do things.

                Comment


                  Rebled the brakes, they feel great now.

                  ABS still isn't working, replaced all the hardware, so it has to be somewhere in the wiring.
                  I do things.

                  Comment


                    I spoke too soon.

                    Driving down the interstate, boom, hard pull to the left. But, I can feel the ABS module pulsing through the pedal. That's new.

                    So something is giving the ABS module, or computer bad information. Possibly a sensor, or something, again, has to be in the wiring.
                    I do things.

                    Comment


                      Damn, fingers crossed you get the brakes sorted. Mine gave me fits before the overhaul. Can't remember if you've tried the ABS relays as a possible issue?
                      Albie

                      '86 325e Zinnoberrot /// '02 325ci Schwarz II /// '18 M4 Azurite Black Metallic ///

                      Albie325 Build Thread | Albie325 Feedback | Albie's M4 European Delivery

                      Comment


                        Melon's E30 Build.

                        I donít have abs but did you torque down everything correctly? Perhaps reservoir Has dirty fluid . Mine is driving me crazy I feel a light clacking on drivers side. Just did hub replacement. When I press the brakes it stops but when I let go itís a rhythmic clacking, Iíll let you know what I figure out and try to help

                        Comment


                          Originally posted by Albie325 View Post
                          Damn, fingers crossed you get the brakes sorted. Mine gave me fits before the overhaul. Can't remember if you've tried the ABS relays as a possible issue?
                          Yeah, I cycled the pump when I bled them too.
                          I pulled the under-dash relay. Cutting the power solves the issue. It just doesn't have ABS, drive great tho.

                          Originally posted by Sonny View Post
                          I donít have abs but did you torque down everything correctly? Perhaps reservoir Has dirty fluid . Mine is driving me crazy I feel a light clacking on drivers side. Just did hub replacement. When I press the brakes it stops but when I let go itís a rhythmic clacking, Iíll let you know what I figure out and try to help
                          I bled the while system from dry, so it's got nothing but brand new Ate200 fluid. I've been checking all the bolts periodically. Your clacking might be a warped rotor, or a pad sticking.

                          Also, the transmission is leaking fluid pretty regularly. I'll top it off before the trip, but I might need to pull it and send it off the have all the seals replaced.

                          I replaced them, and it appears to be the vent and shift selector seal. I've replaced that damn selector seal three times, with the last time shoving two in there, with the other edges coated in Curil K2.
                          I do things.

                          Comment


                            Melon's E30 Build.

                            Originally posted by Melon View Post
                            Yeah, I cycled the pump when I bled them too.

                            I pulled the under-dash relay. Cutting the power solves the issue. It just doesn't have ABS, drive great tho.







                            I bled the while system from dry, so it's got nothing but brand new Ate200 fluid. I've been checking all the bolts periodically. Your clacking might be a warped rotor, or a pad sticking.



                            Also, the transmission is leaking fluid pretty regularly. I'll top it off before the trip, but I might need to pull it and send it off the have all the seals replaced.



                            I replaced them, and it appears to be the vent and shift selector seal. I've replaced that damn selector seal three times, with the last time shoving two in there, with the other edges coated in Curil K2.


                            Are you using redline MTL? The PO of my car took it to a shop that filled her with regular easily leaking ATF.

                            Comment


                              I used Redline in all my transmissions and differentials, unless specified by the manufacturer.

                              Getrag 260 Redline MTL GL-4 75w80
                              I do things.

                              Comment


                                Getting ready to take the E30 on her first trip to TN.

                                I'm beyond excited for this. Hitting the mountain roads us exactly what I built this car for, and after over a year of hard work, I'm finally going to put it through it's paces and drive it like it was always meant to be driven. Pics will definitely be posted.
                                I do things.

                                Comment

                                Working...
                                X